Forum Thread: Kali Linux External Wifi Not Working?

I have 2 external wifi cards. Alfa awus036h and TP-link WN722N. I'm using Kali 1.1.0 on Virtual Box.

Here's what I have tried my Wi-Fi cards with only to end up unsuccessful.

1) Tried with Network settings (on Virtual Box) set to 'NAT' and also with 'Bridged Network'. Checked USB 2.0 and added my wifi card.

2) Tried both Virtual Box and also Vmware.
3) Tried with both Kali 1.1.0 and Kali 2.0.
4) Tried on both Windows 8.1 and Windows 10.
5) Tried on various versions of Virtual box including the latest 5.0.
6) Tried almost all the fixes available online.

But unfortunately none of those work. Last time it worked was with my Windows 8.1 (I can't remember Kali version but 2.0 wasn't released back then). I then decided to upgrade to Windows 10 and the problem began from there. Kali couldn't list up the available networks. I then reverted back to Win 8.1 (formatted the previous windows and did a fresh install) but still the problem persists. The "Cable Connected" option works just fine. But there are loads of tools that require you to have a wireless interface so I'm missing out a lot.

Currently, I'm using Kali 1.1.0 on a Disc which is working almost fine but I want it to detect my wireless card in Virtual box because I can't go through the hard work of switching between Windows and Linux every time I need to perform a pen test.

Helpful comments will be highly appreciated.

15 Responses

That's a very basic thing you told.
Tried that the very first time to no avail.

Well, you didn't say that. Just trying to help.

Is the adapter even being detected? Can you ping in LAN?

Tried airmon-ng, ifconfig but wlan interface never shows up.

On the top right side the little computer icon that represents networks, upon clicking, shows nothing under WIRELESS CONNECTIONS.

Don't have a lot of time, but google "rfkill". That's most likely your problem.

Tried the rfkill thing. Didn't work.
BTW this is how my connections look like. (screenshot attached)

The little LED on the Adapter is blinking which is an indicator that the wifi adapter is working perfectly fine, just not with the virtual box !

Hi!

Sometimes i have the same problem (awus036nh) on vmware! and my working solution was to disconnect the adapter from vmware and then re-enable again - maybe it's working on virtualbox olso?

It works. But everything else comes to a halt.
Like if I try to use reaver, it gets stuck. Nmap commands don't execute.
Infact all those commands that require a wireless interface cease to work properly.

I'm with you on CHH on Kali2. I wish everyone would just wait until the bugs are worked out.

I'm not even using Kali 2.0
I wrote in the post that I'm using Kali 1.1.0

kali 1.1..0 nt gvng me any result..can anybody tell me..is it working in 2.0 ???

Well i am having problems too.

1 i have an alpha external well it was working for a while now its not. its not injecting packets. i do the wifite and its not sending attacks also when sniffing for clients on a wifi enabled router with CLIENTS its not picking any of them up. i went and did a full format of the computer / reinstalled kali and that fucking shits still not working. its pissing me off.

I have the same problem with my TL-WN727N but I am not on virtual machine I cant compile drivers because Gcc have a bug!!! Please Help Me I am very New to linux I wants to use wifi phisher..

Please reply or even provide me a link I am tired of searching on Google.!

Share Your Thoughts

  • Hot
  • Active