Forum Thread: Airmon-Ng and Airodump-Ng Not Working on Kali Linux

Airmon-Ng and Airodump-Ng Not Working on Kali Linux

Hey guys, I am using an Alfa AWUS036NEH wifi adapter with an extended antenna. My issue is, I start airmon-ng:

airmon-ng start wlan1

and I end up with my device being name 'wlan1mon' instead of the normal 'mon0'... Why??

Then when I go to use airodump-ng, nothing show up even if I am sitting directly in front of my router.. I am very confused.

Thanks in advance for the help!

20 Responses

What's the output of iwconfig? Maybe you just have one wireless adapter, and your USB card is called wlan0...

Never heard of the network interfaces mixing up before, though.

Without my dongle plugged in, I have wlan0.. With it, I have wlan0 and wlan1.

When I run airmon-ng start wlan1 , I usually got my device named as 'mon0' but now it is being name wlan1mon..

It sounds like it is recognizing two wireless adapters with your Alfa card wlan1.

Try using the newly named monitoring interface "wlan1mon" in your other commands such as airodump-ng. It should work just like mon0.

Everything else runs fine,like I tried running airodump-ng and it ran fine besides the fact that no routers were showing up. Hmm.. Do you have any clue why that could be happening?

is there any way to use aircrack-ng for cracking wpa... without alfa on android ??

Because zc is creeping into ng.
OK, better explanation is mon0,mon1 etc. are no more.

It has been replaced by wlan0mon,wlan1mon etc. It was replaced because this is (supposedly) a new and better method to put cards into monitor mode. "With the release of Aircrack-ng 1.2 RC2, aircrack-zc has officially replaced the original aircrack-ng, as the new standard." I liked the old way just fine and so did my scripts..

Sheesh... If it ain't broke, don't fix it! Lol so should I run air mom-zc from now on? Lol thanks for the info though, that's good to know

No, just do things as you did before. Just remember the monitors have new names when doing stuff or scripting.

I've had to rewrite a few of my scripts because of this. Annoying? Yes. But I guess if this is the "newest and greatest" version, I'll have to do what I need to in order to keep hacking along.

I can see that as being annoying, I'm personally having an issue of nothing coming up with airodump when using my external card but they come up when using my internal card

when i entered airmon-ng in kali-linux it shows
PHY Interface Driver Chipset

phy0 wlan0mon b43 non-mac80211 device? (report this!)
It is not showing mon0 interface
please help me to fix this bug...

Having upgraded to Kali 2.0, I'm having a similar issue. Using a netbook without an internal card (So there's no confusion at all with cards!) Renames Alpha card to wlan0mon, have been able to start monitoring using airmon-ng start wlan0, but when trying to start airodump using the updated names, reprts back that "failed: no such device" have also tried using -zc command which isn't recognised at! The only other advice it's given is "Make sure RFMON is enabled" How..? Help appreciated, thanks

Think I've sorted it...having identified the name of your alpha card, ie) wlan0mon. I ran the following commands then everything seemed ok.

airmon-ng check kill
arimon-ng start wlan0 (or what ever name its been given)
airodump-ng wlan0mon

worked for me.

iam having same problem in begining it was not showing any driver or chipset in interface but then i surfed over net and downloaded compact wireless 2010-06-26-p.tar.bz2 it solved my interface problem but iam stuch here at airodump-ng mon command showing no such device

its same problem for me, i also download compact wireless 2010-06-26-p.tar.bz2 and airmon-ng is solved, but when it comes at airodump-ng nothing show up! Plz can anyone help me? maybe its because i use virtualbox and need to use kali with usb or what?

Thank you!

i hate wlan0mon, its annoying, plus it disconnects my connection to the wlan network once it enters monitor mode...

this is why i use mon0 ( i use it to disconnect people on the wifi and stay connnected)

"mdk3 mon0 d -w whitelist"

but with wlan0mon i cant stay connected and be on monitor mode at the same time

is there any way to use aircrack-ng without alfa or any other wireless adapter on android device???

i typed airmon-ng start wlan0 but my network card is not coming in monitor mode ,.. what to do??

First, is your network card connected? Type iwconfig.

Second, is your wifi card aircrack compatible?

Share Your Thoughts

  • Hot
  • Active