Forum Thread: [HELP] [NEWBIE] Lost Wifi Connection in Kali 2.0

[HELP] [NEWBIE] Lost Wifi Connection in Kali 2.0

Hi everyone, this is my first post. I love hacking (after seeing Mr. Robot of course xD) but i'm new to this, actually i know nothing about and just started installing Kali 2.0 couple of days ago. I started messing up with some airmon-ng and aircrack commands. At first i type in "airmon-ng kill check" then it said it killed something i didn't remember, then after a couple of failed attempts on cracking WPA, i quit the Terminal and i started suffering web normally but then i realize that somehow my wifi cannot connect ??? try many ways online to fix but still no hope....then i messed up again with typing "iw del wlan0mon" or "iw del wlan0" (not quite sure remember) then i don't see the Wifi option anyone... TT.TT in airmon-ng it also showed nothing (not even wlan0 or something, just blank)....So is there anyway for me to reset my Wifi state on my device, i mean reset everything back to normal, please help me, i'm new to this and i don't have much knowledge. Any help would be very appreciated. Thanks !!!!

21 Responses

If all that Dont work then try rebooting and boot into recovery mode and then it asks for root password and you type your root password after that it gives you a terminal-like space so u type "sudo ifconfig wlan0(or any other network interface) up" it should work. You can test it by typing ifconfig. If you see the wlan0 interface information then it worked your Wireless card is back. Up and running. Thank you.

Only restart and everything is normal

Maybe this will help.. try these.. they are not steps but different methods

  1. sudo service network-manager restart
  2. sudo ifconfig wlan0 up
  3. Click on wifi button in top bar and see if your wireless is turned on or off...

Interesting. I had a similar issue where my wifi would stay connected for a few moments at a time and then drop suddenly without saying it was disabled or that there was a change in connectivity. I solved it by going into Wifi Settings and disabling ipv6 in my current network's settings. I dunno if this will fix your issue or not, but it worked like a champ for me.

If you set your wireless adapter in monitor mode, you are not going to be able to use it anymore to connect to an AP.

In order to reset it, restart network manager service and set the interface up if necessary.

Or, reboot.

If all that Dont work then try rebooting and boot into recovery mode and then it asks for root password and you type your root password after that it gives you a terminal-like space so u type "sudo ifconfig wlan0(or any other network interface) up" it should work. You can test it by typing ifconfig. If you see the wlan0 interface information then it worked your Wireless card is back. Up and running. Thank you.

Kali linux 2.0 not showing wifi option/ network in live USB mode
please tell how to fix this problem

My problem is SOLVED !!! Tnx guys so much, i absolutely will be more careful next time when i do Airmon :))))

but hey guys, i just wonder if there a way to reset kali to stock form (of course not reinstalling), like factory reset on Android, to help solve problems if something went wrong???

The reason you had this problem is because when you are killing these processes with airmon-ng kill the airmon-ng program kills all processes that can cause interference with your wireless chip being placed into monitor mode. Now this isn't always required, but if you want to connect to wifi after putting your card into monitor mode, you can reboot, or do the commands listed above. Next time try

"airmon-ng check kill" because then it will list the programs it checks and then kill them.

Hey, i think i did the same thing but I'm not sure.
I already tried all those commands but no success.
Wlan is not listed on network-manager tab so I can't search for Wi-Fi.
I can still use wlan0 with monitor mode(airmon-ng) but I can't conect to any network. Reboot didn't solve the problem.

.
Take a look at the screenshot:

Image via imgur.com

If all that Dont work then try rebooting and boot into recovery mode and then it asks for root password and you type your root password after that it gives you a terminal-like space so u type "sudo ifconfig wlan0(or any other network interface) up" it should work. You can test it by typing ifconfig. If you see the wlan0 interface information then it worked your Wireless card is back. Up and running. Thank you.

Hey guys, i came across the same problem with my kali linux. But keep in mind i
am running it on a persistence usb. Theres no wifi network option on the top bar and
My internet isnt working. Im a newdie as well. Ive tried these commands on these replies
But internet didnt doesnt work, ive tried other commands ive learned
On youtube but still no help. So please help me get my internet up and running. Nee

im not expert to linux. just used kali linux as default OS for about a year so...

everytime you run "airmon-ng start wlan0" it will rename your interface to wlan0mon and deleting that interface wont help. use "airmon-ng stop wlan0mon" instead

to recover the deleted interface simply by restarting your linux.

"airmon-ng check kill" is killing NetworkManager ( better to kill it ).
start network manager again by using "service network-manager start".

If all that Dont work then try rebooting and boot into recovery mode and then it asks for root password and you type your root password after that it gives you a terminal-like space so u type "sudo ifconfig wlan0(or any other network interface) up" it should work. You can test it by typing ifconfig. If you see the wlan0 interface information then it worked your Wireless card is back. Up and running. Thank you.

A simple trick is to unplug the wireless adapter and plug it back and you are done!

service network-manager restart this is the command to restart your wireless interface an di works 100%

i reboot aend go through recovery mode. but when i proceed command "sudo service network-manager restart" it shows "network-manager not found. when type "ifconfig wlan0 up" it shows failed.

Hello new user here....also a newbie but i found the proper command its airmon-ng stop wlan0mon then restart your network manager (service network-manager restart)

Share Your Thoughts

  • Hot
  • Active