Forum Thread: Airbase-Ng Error I Need Help Solving.

Airbase-Ng Error I Need Help Solving.

Image via postimg.org

Hello guys. i do not know why it always says got channel -1 even when i type -c 6

10 Responses

This is what worked for me, before you start your aircrack bring down your interface using ifconfig <interface> down. then do, iwconfig <interface> channel < channel#>. then, ifconfig <interface> up. See if that works.

example:
ifconfig wlan0 down
iwconfig wlan0 channel 6
ifconfig wlan0 up

See if that works. Good luck.

thanks!

Greetings this is the network manager issue. All you have to do is stop network manager it will solve this problem.
service network manager stop

Side note: the post above should be using:
ip link set dev wlan0 down
blah
ip link set dev wlan0 up

thanks a lot!

Thanks for the tip CYberHit If you don't mind me asking whats is the difference between iplink set dev and using ifconfig like i am above?

The only difference is that ifconfig is Deprecated now and you should move to update the syntax used.

isn't it a matter of preference though? i mean i have nothing against using iproute2 but is there really any difference, besides the commands?

You are correct and it will kill wpa_suplicant and the dhcp. we need the wpa tho.

thanks a lot to you guys!

No worries.
You had a few more options to try but someone sniped the posts for NO reason at all.

Share Your Thoughts

  • Hot
  • Active