Forum Thread: Whenever I Try "Airmon-Ng Start wlan0" There's an Error?

Whenever I Try "Airmon-Ng Start wlan0" There's an Error?

Everytime I type in "airmon-ng start wlan0" the following error comes up:

" wlan0 is hard blocked, please flip the hardware wifi switch to on.
It may also be possible to unblock with "rfkill unblock wlan0"
Detected VM using dmiinfo
This appears to be a VirtualBox Virtual Machine
Some distributions have bugs causing rfkill hard block to be forced on in a VM.
If toggling the rfkill hardware switch and "rfkill unblock wlan0" both fail
to fix this, please try not running in a VM.
rfkill error, unable to start wlan0

Would you like to try and automatically resolve this? y/n y

Newly created monitor mode interface wlan0mon is NOT in monitor mode.
Removing non-monitor wlan0mon interface...

WARNING: unable to start monitor mode, please run "airmon-ng check kill""

What should I do? My wireless adapter is a wireless AWUS036H. Thanks in advance!

-Brooku

10 Responses

hey bro I have no idea abt u r problem because i m an new user for linux
but i think u can solve my problem
my ploblem is how to instrall various tools in linux

Google it pal, should help.

You have to set your adapter to monitor mode first:

airmon-ng start wlan0
airodump-ng wlan0mon

The error I asked above comes up whenever I type "airmon-ng start wlan0" which is:

"wlan0 is hard blocked, please flip the hardware wifi switch to on.
It may also be possible to unblock with "rfkill unblock wlan0"
Detected VM using dmiinfo
This appears to be a VirtualBox Virtual Machine
Some distributions have bugs causing rfkill hard block to be forced on in a VM.
If toggling the rfkill hardware switch and "rfkill unblock wlan0" both fail
to fix this, please try not running in a VM.
rfkill error, unable to start wlan0

Would you like to try and automatically resolve this? y/n y

Failed to set wlan0mon up using ip

(mac80211 monitor mode vif enabled for phy0wlan0 on phy0wlan0mon)
(mac80211 station mode vif disabled for phy0wlan0)"

So I tried "rfkill unblock wlan0"

It says "Bogus unblock argument 'wlan0'.

Then I type "iwconfig"

And suddenly it says "wlan0mon" Mode: Monitor.

However even though it's somehow on Monitor mode I can't execute the command "airodump-ng wlan0mon" Because if I do, this comes up

"ioctl(SIOCSIFFLAGS) failed: Operation not possible due to RF-kill"

Sorry for the long reply!

Try running "airmon-ng check kill" then airmon-ng start wlan0

Tried that, however the error "ioctl(SIOCSIFFLAGS) failed: Operation not possible due to RF-kill" now comes up.

Thanks for your answer

Hey Jun,

  • Fix RFKILL Hard Block

just add this line in blacklist.conf in /etc/modprobe.d/
"blacklist wmi"

  • Permanently Fix airmon-ng monitor mode error

I just covered a similar issue with aircrack-ng on my blog post.

Here you can head over to "Resolve Airmon-ng and network manager issue" section. There is the solution for this issue which'll help you fix network manager so that you donot have any need to run "airmon-ng check kill" everytime.

Just airmon-ng start wlan0
and you are good to go.

Go here

I hope it helps.

It doesn't help, but thanks though!

Try:

iwconfig wlan0 down
ifconfig wlan0 mode monitor
iwconfig wlan0 up

airodump-ng start wlan0

My good friend, I personally had this problem and here is is how I fixed it.
(NOTE: this only works if your soft blocked)
To know if it is soft blocked do "rfkill list"
If it's soft blocked type the following:
"rfkill unblock wifi" what this does is it tells the kernel to re-activate your wifi systems.
"rfkill unblock all" this will basically unblock everything via kernel's help.
Hooe this helps!!!

Share Your Thoughts

  • Hot
  • Active