Forum Thread: No Wireless Extensions in Linux Debian

Hello WonderHowTo-Community!

I have a problem with my Wifi on kali. I run win 10 and I boot kali from a external hard drive. When I type in the shell: iwconfig it says "No wireless extensions found".

If I run airmon-ng check kill and then airmon-ng start wlan0 it gives me this error code:

ls: cannot access '/sys/class/ieee80211/': No such file or directory.

Thanks for the help!

Never Miss a Hacking or Security Guide

New Null Byte in your inbox, every week.

2 Responses

that means that the wireless adaptor which is imbedded to ur laptop is not fully configured to the kali system ...all u have to do is to try to configure the wireless card .visit this videos and i think it shall help u https://www.youtube.com/watch?v=SkNlZZ-nY2c and follow the steps ...but i think ur usb live kali must bE presesited to avoid this problem every time
hope that answers ur Q

*

Thanks for your response man!

But if I restart my laptop, I need to configurate all again. Any tipps? (My linux is installed on the external hdd).

Share Your Thoughts

  • Hot
  • Active