Forum Thread: Broken Nmap

Hi everyone

Yesterday i ran a sudo apt-get update && apt-get upgrade and then i turned off my pc. Today I turn it on and nmap doesn't's like stuck at the very begging here's an image :

it's basically stuck on the "Starting Nmap" ...anyone has any suggestions please?
I have tried to run it since all day (i just tried to run it again few minutes ago as you can see)
P.S. i was trying to run a simple scan of an Ip on one single port (24)

10 Responses

Can u try to scan the localhost IP.

It does the same just loads for ever

Press any key, what does it say?

it increases the verbosity level to one but it doesn't do anything next...however thank you's already something

Oh yeah, you can run nmap with -vvv and it should tell a lot of info about what is happening.

running sudo?

Already done ...both sudo and -vvv
Nothing happens...

Press an arrow key. It should say at what stage it is stuck on.

Is this Kali 2? In Kali 2 there is an nmap glitch where it doesn't automatically output the scan as it happens. Press any key (I do space but it doesn't matter) and it should update.

This has happened to me as well. I ended up just waiting for over ten minutes before it kicked in and started displaying output. So try to let it sit and see if anything appears.

Share Your Thoughts

  • Hot
  • Active