Forum Thread: Getting Error in Android Meterpreter Session

Hi , I've played around with a lot of android payloads(raw) recently with msfvenom on LAN without any problems. But this time i decided to try it over WAN . I made a reverse-tcp backdoored android payload using fatrat , i had some issues with port forwarding so i used ngrok for that purpose. I download a valid apk application and decompiled it with apktool , embedded my payload into it and also inserted the hook. Then i recompiled it and successfully signed it with jarsigner. I started the listner , downloaded the modified app on my phone (connected to another network) and got the meterpreter session without any problem.... But when i tried to run some commands, none of them worked giving an error : Operation failed: 1...

I am running kali 2017.1 on a live usb with persistence. Any help would be appreciated.
Thanks.

4 Responses

It happens sometimes because connection over WAN is unstable. Whenever u successfully get a meterpreter session, first make it persistent. Cellular network is sometimes nit stable in india u knw. xD

Thank you very much for replying , are you sure that it is normal for metasploit to sometimes give this error on WAN , cuz this is vey annoying . I spent a lot of time creating the infected apk and at the end it didnt work.BTW. im from Pakistan xD

Try using Armitage. It'll be easy fr u to work on WAN connections.

Thanks a lot, I'll be sure to give it a shot

Share Your Thoughts

  • Hot
  • Active