Reverse Connection Fails: Metasploit

Reverse Connection Fails: Metasploit

The metasploit framework doesnot connect to the remote payload it is just stuck on starting payload handler. It was working fine few days ago with the same payload bound with an apk. Now its not connecting when I start the app. All commands are correct. It usually fails to connect to the database. Can anyone help whats the problem and how to fix it..

12 Responses

Local network or WAN? If local, has your local IP address for Kali changed? If WAN has your WAN IP changed?

I am using on WAN. I have payload packed with no-ip ddns and had it updated so no ip issue. Any help..

Ok. Now go into terminal and type ifconfig Your local IP address will be listed. Go into your router configuration page and make sure that same IP address is port forwarded. If you have a different local IP address than before, you can set your router to assign Kali a static IP address.

The ip address is same as before, and the forwarded port (4444 in my case) is correctly assigned to the listener. But still not working..

Check to make sure the listener is working. Go to the Android phone, type your DNS address and port in the web browser. Ex http://websitename.noip.com:4444

If your listener is setup correctly it should show an http get command in Metasploit.

Yeah it worked fine when I updated the framework yesterday, and started the postgresql service as /etc/init.d/postgresql start. Thanks bro for your help.

virtual machine se chala rahe ho aap ya installed kari hai kali linux?

akanksha metasploit wala apk auto install ho jaye aisa kuch pata hai aapko ya phir link se seedhe shell mein inject ho jaye payload???

Does anyone knows how to set multiple rhost in metasploit. i basically want to exploit multiple targets at a time and get all meterpreter sessions at once. and someway execute commands on all sessions at once.

Use Armitage. In terminal type msfdb init. Then open Armitage. Armitage is a gui version of Metasploit and it makes it easier to deal with multiple sessions.

thnx man for the help.

How do i convert my EXE or JAR files to .pdf .doc .rar ETC..... to silent mode in kali Linux withou affecting the file. any help please

Share Your Thoughts

  • Hot
  • Active