Forum Thread: TP-Link WN722N v2 on Linux 5.5.0 Not Working

Hello i'm new to linux 5.5.0, i've installed the correct drivers for rtl8188eu/eus for previous Linux version.

Today i decided to switch to the newer version of Linux 5.5.0-kali2-amd64 #1 SMP Debian 5.5.17-1kali1 (2020-04-21) x86_64 GNU/Linux.

So i installed the new version on my VMware Workstation and tried to reinstall previous drivers for the WN722N v2 that is present on github in various ways.

I have a series of errors that i cannot understand i will write them here :
*make 2: ** /root/rtl8188eus Error 2
make1: ** sub-make Error 2
make1: Leaving directory '/usr/src/linux-headers-5.5.0-kali2-amd64'
make: ** Makefile:2286: modules Error 2 *

I tried to remove the 8188eu.ko folder but... :
*E: Unable to locate package 8188eu.ko
E: Couldn't find any package by glob '8188eu.ko' *

So i thought that i wasn't installing in the right way, so i tried to reinstall it from git hub :
git clone github.com/kimcoder/rtl8188eus.git

And in return i had :
fatal: destination path 'rtl8188eus' already exists and is not an empty directory.

So the folder rtl8188eus is already there but does not make me run any "install" commands.

I also tried with other version of the 8188eu driver with the "kernel" version found on github.

I always had this string in response :
*iwconfig wlan0 mode monitor
Error for wireless request "Set Mode" (8B06) :
SET failed on device wlan0 ; No such device*
I need to solve this, sorry for my eng i'm not good with it ahahah.

Our Best Hacking & Security Guides

New Null Byte posts — delivered straight to your inbox.

2 Responses

Thanks for your response.
i will try this !

Try these cmd
apt update
apt upgrade
apt update

Share Your Thoughts

  • Hot
  • Active