Forum Thread: Ethernet Isn't Working on Kali Linux(Recovery Mode)

Ethernet Isn't Working on Kali Linux(Recovery Mode)

It all started when i was trying to change my display manager from Gnome to KDE, I ran this command to remove Gnome:

sudo apt-get remove gnome-core kali-defaults kali-root-login desktop-base

Then i ran this:

sudo apt-get install kali-defaults kali-root-login desktop-base kde-plasma-desktop

but then my laptop lagged so i had to restart it and then the Grub loading menu has changed a bit and when i booted to Kali i get stuck in a black screen, even the log in menu doesn't appear so I tried to go to recovery mode to download a display manager by using an Ethernet connection but when i tried the previous command again it showed the same thing, it couldn't connect to the internet, one of the good guys here tried to help me (Ciuffy) by telling me what, so i shutdown the laptop, plugged in Ethernet connection,booted to recovery mode again and tried ifconfig but i only get the lo, no eth0 or wlan0 (sorry i couldn't upload an image because i kept getting errors)

and my kali version is 1.0.9
its gonna be hard to reinstall kali from the start so i hope someone can solve this
Thanks in advance

12 Responses

(I never had/saw this issue before so..)
Greetings, Let's first try :
ip link show eth0
ip link set eth0 up

it shows eth0 now when i run ifconfig but still there's no net.
when i unplug it, it shows eth0 is down and when i plug it in back it shows eth0 up.

the connection is working fine on windows but don't know why not on recovery mode, im trying to upload an image for the ifconfig but im getting 'HTTP error'

Before or after ip link? if after you need to add dhcp and routing to be able to get out.

Just in case (if not file=dev/null):
iw eth0 link
dhclient eth0
ping 8.8.8.8
ip route add default via xx.xx.xx.xxx dev eth0 #<---#Add IP of the box in question.

i get 'Not connect' when running 'iw eth0 link'
then i get 'Reloading /etc/samba/smb.conf: smbd only.'
'RTNETLINK answers: File exists'
when running 'dhclient eth0'
and its pinging normally with 64 bytes i guess
but i didnt understand the last one, if you could make it more simple please

ip addr show eth0
Wait, do you have an ip? Can you get out?
IF not get out and yes you have an IP continued:
ip route show
Add that address to the replace the x's
ip route add default via xx.xx.xx.xxx dev eth0

it worked!! thanks a lot :)

Congrats Cyber, your experience is always so helpful.

I concurr! Knowledge and patience is an incredible and rare combination.

Glad it worked out.
@CIUFFY & OTW Thank you for that.

Side note the same method can also be used for wifi. Just need to add 3 steps. config,call wpa supplicant, scan, connect.

no after ip link
every time i boot to recovery menu, eth0 doesnt show unless i type those commands you gave me:
ip link show eth0
ip link set eth0 up

Please , I need help,

When I power on my Kali .2.2016 , it says that the internet manager failed to start and its stuck at the black screen, ive tried to start it from the recovery mode and is says that the system failed with a code of something like that, see systemctl status or journalctl -XE ,

Share Your Thoughts

  • Hot
  • Active