Forum Thread: Network Issue in Kali Linux Using VirtualBox

Hello My friends !! , hope you're all alright

I'm using kali for a while i stopped a bit because i was busy with other things , Anyway i returned but there is a weird issue with the network

I have my Virtual box network adapter to bridged but in kali connections there is : Auto Ethernet , and however i try to connect it takes time and doesn't do anything it just fails

Tried to restart Network-manager , no results
Any help would be appreciated :)
Cheers

60 Responses

Could you post pictures please? Both of your settings and Kali?

Before i was able to connect normally on ifupdown connection, but dont know what happened i left virtual box and kali untouched since then how this happened the last thing i remember i did was making proxychains and other stuff internet was working like a charm --

It's possible it could be an issue with the wifi and not the software. I suggest that you restart your computer, and test it on some free starbucks wifi. I'm not that good with networking, but I know that a good reboot and reinstalling some software can really clear things up.

Just curious what is the disabled connection?

Try enabling it and then try using it? I don't know just guessing...

I Have Wired Connection !!

Make sure that the realtek device you have running works with your host machine first. Also, I would suggest that you have the bridged adapter set to your regular default adapter for your host machine, and your realtek device can be configured under the "usb" section.

Yeah My realtek device is the same as my host anyway it's only one so there is no options Adapter type is : Intel PRO/1000 MT Desktop (82540EM) it's correct isn't it ?

you said it can be configured under the usb section !! where? :\

Yeah, use the option #1, not the PCIe controller.

there is no other options sadly :\

Kali network and internet was working perfectly with these settings dont know what happened !!!
I'm confused

By any chance did you look in your logs for anything?

Your Kali sys logs. Applications > System Tools > Log File Viewer would be the easiest way to see them.

Alright hold on ...
is there is anything in particular I have to check?

I can't find my network device in Devices - Usb devices , is this fine ?

These Are some of the logs in the system log file
Check from below someone might get my issue
I don't know what the hell is wrong kali was working normally before , then i left it untouched ... now BOOM ! :|
Hope someone with the right knowledge can help :)
Thanks Dill for the help and thank you everyone
Jun 27 09:40:27 Root NetworkManager2331: <info> (eth0): IP6 addrconf timed out or failed.
Jun 27 09:40:27 Root NetworkManager2331: <info> Activation (eth0) Stage 4 of 5 (IPv6 Configure Timeout) scheduled...
Jun 27 09:40:27 Root NetworkManager2331: <info> Activation (eth0) Stage 4 of 5 (IPv6 Configure Timeout) started...
Jun 27 09:40:27 Root NetworkManager2331: <info> Activation (eth0) Stage 4 of 5 (IPv6 Configure Timeout) complete.
Jun 27 09:40:38 Root dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 21

Jun 27 09:40:49 Root NetworkManager2331: <info> (eth0): device state change: ip-config -> disconnected (reason 'user-requested') 70 30 39

Jun 27 09:40:49 Root NetworkManager2331: <info> (eth0): deactivating device (reason 'user-requested') 39
Jun 27 09:40:49 Root NetworkManager2331: <info> (eth0): canceled DHCP transaction, DHCP client pid 3163

I just tried to add a NAT adapter , internet is working and eth1 is configured but i need bridged ...
I think my issue remains with eth0, when i type in ifconfig , there is no ip shown ! , is that bad ?

So it works in NAT but not bridged? Is your computer connected to a router or directly to a modem, just wondering.

Ya it does working on kali now with NAT but strange you know i used to use it with bridged with no issues , no to a router via cable the router connected to the modem by cable too

O.O Whoa....
Have you edited the /etc/NetworkManager/NetworkManager.conf. and set managed to true yet?

I can't tell if your saying yes you tried that or not. I had thought of that, but was expecting to see more of a device not managed error in your logs.

I had an issue just like this the other day. It was not showing eth0, so I edited that and restarted network-manager and it was fixed.

I think the reason why nobody can figure out the problem is because we still don't have enough info.

First tell us:

  1. What is your host machine?
  2. How is your host machine's connectivity is set up?
  3. Are you using external adapters at all?
  4. What version of kali linux and virtual box do you have?

Correct apologies for that
1- Windows
2- Via Wire cable from my pc to the router from the router to the modem
3- No I'm not using any external adapters
4- Kali : 1.1.0a latest VirtualBox: 4.3.28
Anything else I'll be happy to answer :)

I'd try CYBERHITCHHIKER's links, they look promising. At this point an uninstall and reinstall would be a good option. Your logs are what seem most interesting to me, it starts the dhcpdisscover then disconnects and cancels. Reason user-requested. Seems like something is just taking control and not allowing it to complete. I saw some articles on IPv6 getting in the way and setting it to link local only was the solution, but I doubt that is the problem here.

Yeah his links are very interesting
I think I'll reinstall virtualbox

Im checking out option 1
turns out that i have in the virtual box adapter
VirtualBox Bridged Networking driver check box unticked for some reason
Continuing on Reading the problems and solutions ....

i'll inform you guys of the outcome
I'll check a way to save my virtual session , is it possible ?

Your VM? It's just files, save the files?

No I mean the session ( the virtual box session) so I don't have to install kali again with everything I've done on it

if i back up Virtual box .vdi image file will that save my Kali linux stat and contents

Uninstalled Virtual Box , reinstalled it same issue !!

I Tried Alot of solutions from the links that cyber gave me

Nothing seem to work I'm just stick with NAT, And when it comes to Bridged I have the wired network to Auto Ethernet , it keeps connecting and disconnecting ... I'm really confused :\

_

Something weird is going on just now , this time I kept both Bridged & NAT , in Kali I can disconnect from both of them and switch in between them : ( eth0, eth1) !! :S

Does this walkaround fix the issue or I'm still Running under NAT not bridge ?

nah forget it eth0 ( Bridged ) internet is not working yet , but NAT is working normally , it's really annoying

Sorry you are still having issues. This is the main reason I don't use VBox.

:\
So there is no solution then ?

Better yet, create a usb persistent version of kali.

Im not really sure, Kali works, this issue is in VB setup or in the last update. The same as half of its users having some type of issue with it. So I used VM Ware without thinking twice about it. I see on kali.org they have a few different patches for VB so that says a lot about Vbox to me.

Think back did anything get changed or updated since you used it last working 100%?

I am also sorry you are still having issues. I believe we may have reached the point where an online forum can only do so much. Didn't you have networking issues awhile back with Kali on virtual box, port forwarding issues? Either way it may be time for you to try something different. I prefer VMware but that's just my personal opinion (to each their own). Try it and see if it helps with your problems.

Alright isn't VMware paid ?

Some of the products, yes. However, VMware Player is free. Just so you know, though, many people have complained about performance issues with VMware Player.

Hmmm.
Let's see.
Performance issues - Not working at all....
Performance issues - Not working at all....
;-P

lol, yeah.

I've had some problems with Kali in VMware Workstation too. The longer Kali was running, the slower everything got. But Workstation is probably the best cheap one

Oh , I'm thinking in moving to VMware , is there is a cracked version working ?
Because I found a keygen for VMware Workstation 10

Or if someone could help me solve the issue i have with bridged adapter on virtual box I'll stick with virtual box

I installed Win XP guest on my Kali 2.0 host and I cannot communicate with it. I tried nmap and ping and it says all the ports are filtered/blocked!

I've tried Bridged adaptor and all the rest, I'm trying NAT with port forwarding but nothing seems to work. Firewall is disabled on the guest.

Can anyone tell me why the ports are unreachable? Any help would be greatly appreciated, I'm tearing my hair out.

Share Your Thoughts

  • Hot
  • Active