Forum Thread: Virtualbox Kali Bridged Connection Issue

Virtualbox Kali Bridged Connection Issue

Hey guys, I want to use the Bridged Connection Option with Kali 1.1.0a in Virtualbox. I am currently utilizing a Macbook Pro (Early 2011 Model) running OSX El Capitan. The version of Virtualbox installed on my Mac is 5.0.12 r104815. I have done a lot of different tests to try to pinpoint the issue, including:

  • Reinstalling Virtualbox (FAILED)
  • Installing an Older Version of Virtualbox (FAILED)
  • Posting on the Virtualbox Forums (No Answer After Over a Week)
  • Trying the Same Tests on my Bootcamp Install of Windows 7 (FAILED)
  • Making Use of a Ethernet Cable Bridged Connection (WORKED)

From my research online this seems to be a recurring issue with a lot of people. I don't really want to be confined to constantly using a ethernet cable every time I want to interact with the local network, so any help here would be much appreciated!

Below You Will Find My Virtualbox Network Settings:
Enable Network Adapter: True
Attached To: Bridged Adapter
Name: en1: Wi-Fi (AirPort)
Adapter Type: Intel PRO/1000 MT Desktop (82540EM)
Promiscuous Mode: Deny
Cable Connected: True

2 Responses

Some APs don't allow the assign of different IP addresses to the same device. I don't know what do you want exactly, but you can change the network settings to NAT.

Yeah, I'm pretty sure that's the issue at this point, because I tried to get a Bridged Connection working on a totally different device, and was still unable to make it connect appropriately. I suppose a good test would be creating a hotspot on my phone, then seeing if the bridged connection works, if it does the problem is definitely the result of a bad AP configuration.

By the way, I am also getting an error:

Bad Archive Mirror, when installing Kali 1.1.0a, is there any solution to this that you know of, because I have been at this for a few days, and have been unable to successfully complete an install.

After research, however, I was told I could fix this later after the install, but then I got a Grub Installation Failed error also, which is a much more major issue. Is Kali 1.1.0a not supported now that 2.0 is out? Because, I see no reason why I shouldn't be able to install these things.

Share Your Thoughts

  • Hot
  • Active