Forum Thread: Problems with TL-WN722N V2 (Monitor Mode)

15 Responses

It will not work. See my latest post on wireless network adapters.

v2 uses a chipset that does not support monitor mode, v1 uses the compatible chip.

I made this mistake myself. Spent ages trying to get it working before I realised I had the v2. Amazon took it back. Get an Alfa.

how does one check the version? is there a command i can run in the line, cuz i bought the same TL WN722N, but am not sure if its v1 or v2. would it just be safe to return it and just buy one that i know will work? also... i had the page saved where it went through the setup of the wireless adapter for the kali Pi build to get it ready for packet injections etc. , but cannot seem to find it now.. if i could get a point in the right direction that would be awesome.. still a newbie but i really wanna get a hang of this.

I haven't had a chance to try this, you've used it?

Tengi, that for sure works? Sorry to ask when you seem so positive, I just need to know whether to return this and just get a panda.

I've tested it. It works, I can now enable Monitor mode. Now airmon-ng works fine!

Francisco, how did you manage to make it work though ? I don't want to open another thread to ask the same questions :(

@Shiro Dider, same here. I am also looking for the same answer on existing threads . Hope we find an answer soon ??

Yea bro, i've been trying to find an answer, everytime i looke on forums theres people saying that it doesn't work and others that says it does work :(

Hey guys, I just tested the mfruba/kernel and it works for my v2 on kali. All I did was make, make install and then reboot

on what carpet file did you execute that commands?

Share Your Thoughts

  • Hot
  • Active