Forum Thread: TL WN722N Usb Not Detected in Kali Linux 2017.1

Hi, i bought a new tp-link Tl WN722N V.2 wifi dongle for wifi hacking but when typed ifconfig, there is no wlan0 interface,so i checked if the system is even detecting my usb by typing # lsusb but there was no mention of the chipset or vendor name, just some ID 2357:010c.

First i typed # lsusb without the usb and the i typed it after plugging in the usb. I searched a lot of forums but none of them worked for me. Im am runing kali 2017.1 live with persistence on a usb. The Linux version is 4.9.0-kali3-amd64. I found the driver zip file but i dont know where to put it or how to install it. Im in desperate need of help . I am a beginner and need detailed help. I'd be thankfull

24 Responses

This is how you should fix this type of error.

I did all the steps as shown but there was a slight difference in the ouput during the process...

...this was his ouput after # make load, whereas....

...this is mine. Fortunately i got the wlan0 interface at the end but i no wifi appeared when i scanned. After i rebooted, the wlan0 agian disappeared.

And even after i got the wlan0 interface, my router's light was still off.
Please help

Well here's a final tutorial that will probably resolve your problem if it doesn't resolve your problem i will try helping you manually but don't expect too many replies from me i am busy mostly. Good luck resolving your problem

Is it usb 3.0/2.0? Are you using virtualbox or something?

It is usb 2.0 and no i am not using a virualbox. I am using kali live with persistence

Thank you very much for sparing your time and i am really sorry to bother you, but i cant get through this alone. The video which @L L shared shows tutorial for a virtual machine but i am running kali live from usb. I followed a tutorial and downloaded compat wireless and got the wlan0 interface ...

But i am unable to scan wifi ..

This is because the usb is not on because the green light is off and that is probably because i havent installed the right drivers i think.

It is clear that the # uname -r shows 4.9.0-kali3 while the headers inatalled are 4.9.0-kali4

Further when i try to make file , two errors occur..

I researched about it and got to know that to end these errors i need to download headers, but when i try to download headers another shit happens..

I understand how hard this is for you and i value your time, but the thing is that i am pretty messed up right now and i need some help to get through this.

Few more details...

Please somenone help me

Try doing this:
apt-get update
apt-get upgrade
(Wait till it reboots)
(Put your adapter and resume following these commands)
ifconfig (check if kali detected your adapter)
airmon-ng start wlan0 (this will put your wlan0 interface in monitor mode)
iwconfig (check the name for your interface that is in monitor mode, for me it's wlan0mon yours may be different)
airodump-ng <interface that is in monitor mode>
This will dump/scan WiFi in your area, and display some key information about every network it finds.
Good luck

Thanks for replying, i have run these commands thousand times but no wifi is detected because the router does not start and that is because of missing drivers and appropriate kernal headers. I have the drivers but i need help on how to install them in the proper directories and how to download kernal headers that match my kali's version.

then i am afraid i can't help you, try posting this on some other forums or post this again on null byte and update it with every picture that displays error you want to get rid of.

Good luck


@L L, finally i got to know what the actuall problem is, By typing uname -r, I see that Linux is booting on 4.9.0-kali3-amd64 and not on 4.9.0-kali4-amd64 and when i try to #make the driver file, it cannot find 4.9.0-kali3-amd64 headers because they are no longer available as the update/upgrade downloaded the new kernel headers for kali4which i confirmed through #apt cache search . After I looked for solutions on the internet I found that because it is running on Live USB with persistence even after the update the kernel that Linux will boot on is the one from the downloaded ISO. But then i found this post: . This guy seems to have found a solution but i am unable to understand some of his steps, more precisely i dont know where he moved the image file from. Can you please read his answer and elaborate the steps, i woulb be thankfull.

Actually, instead of messing around with the boot files, i downloaded a new weekly image which has by default 4.9.0-kali4-64 kernel version, then i downloaded the kernel headers without a problem and installed the lwfinger rtl8188eu driver peacefully and finally the router sprang to life . I can use internet and surf on the web but now the problem is that when i try to put it in monitor mode by # airmon-ng start wlan0, there are some processes that need to be killed , but as soon as i kill those processes my router turns off. Then i have to reboot to get it back on but still cant get it into monitor mode ??

I think you can probably help me out with this one...

More details...

Please help me

I'm also running live-usb persistence but also have the same error. My wireless adapter is TPLink T2U and I can't install the driver mt7610uwifistav3002dpo_20130916.... Maybe the kernel is still 4.9.0-kali3-amd64...I tested my wireless adapter on virtualbox and it's running on kerenel 4.12.0-kali2-amd64.... I prefer to use live-usb due it's more faster than virtualbox....Pls. let me know if you have solve the problem since I'm still searching for it...

Thank you

Don't kill your Network-Manager

Same with me...... If I type airmon-ng start ra0, it will not be on monitor mode. But if you go on type airodump-ng ra0, it will dump packets but the pwr=0...and it cannot get a handshakes. ra0 is already on monitor mode by this time if you check iwconfig.

Any idea....Thank you

Hey, you need to run:
sudo airmon-ng check kill

BEFORE trying to put the adapter in monitor mode. You will not be able to use WiFi for internet access so you will need to use wired ethernet while using the WiFi adapter. (From my understanding... )

stop spamming your worthless scam....

Hey, Just saw this. The V2 of the TP-Link WN722N does NOT support monitor mode! Only the V1 of this USB wifi adapter will work well for Wifi hacking, and it is EXTREMELY hard to find nowadays, and if you do find it, it will most likely be around 40-50 USD! In that case might as well just buy "The Cockroach" - ALFA AWUS036NEH Long Range WIRELESS 802.11b/g/n Wi-Fi USB Adapter... Here's the Amazon Link: ALFA AWUS036NEH Long Range Wireless 802.11b/g/n Wi-Fi USB Adapter

Sorry you had to suffer so long! You really can't go wrong buying the AWUS036 NEH!

I have almost the same problem. At #lsusb command shows 2357:010c . And what i need is to fet it in monitor mode, but it doesn't work.

Can you help me guys ?

Even me too stuck with the same problem i really searched a lot on the net but didn't find a single relevant solution for this can some one help us !

Guys..only V1.0 is working ? I have found V1.1 and V1.9 and don't know if I should order or not ...

You can Finally Enable Monitor Mode and Packet Injection on TP-Link TL-WN722N v2/v3 on Kali Linux running kernel 4.19 by following this tutorial:

Share Your Thoughts

  • Hot
  • Active