Forum Thread: TP-LINK TL-WN722N Problem Woth Kali Linux

TP-LINK TL-WN722N Problem Woth Kali Linux

This adapter is working fine at first, when i type the command ifconfig, wlan0 appears, also in iwconfig and also in airmon-ng, it displays the interface. I was able to perform aircrack-ng to the point I was cracking the password but unfortunately, after 2 million key phrases, it didn't crack the password. I was going to perform another pentest and here is the problem, virtual box doesn't recognize the adapter, it was captured, yes, but now wlan0 doesn't appear anywhere in the commands i used. I really don't know what went wrong because i didn't change anything in the settings. Any insights or solution to this problem.

Tell me if i need to send some screenshots.
Note:
I have Kali Linux 1.1.0
Running the latest version of virtual box with the updated extension pack.

7 Responses

So just to make sure, kali detected the WiFi dongle at first but not any more? If so did you try the unplugging and re plugging, turning off and on your computer? If this doesn't work you could always just revert to an old snapshot, although that may not be an option for you.

Cheers,
Washu

VirtualBox can be a headache with wireless adapters, I recommend to use VMware. I also have a TP-Link TL-WN722N and had the same issue on VirtualBox, with VMware works flawlessly.

@Washu Washu Yes, i already did it. I replugged it, turn the VM OFF and also my PC. But still the same problem.

@Jako I tried VmWare once but i did get the same problem, I was wondering on how you made it work for you. Did you modify the settings and change something. Please let me know.

I didn't modify nothing, what main OS are you running? Windows?

Yes I'm using windows as my main OS. I JUST DOWNLOADED VMWARE andI think the same problem is occurring when disconnecting the adapter from the host.

Hey people, I downloaded VMWAREandtge problem is the same. The adapter is captured but i don't think that itbis mounted on the Virtual Macine. My adapter turns off after it has been disconnected from the host which I think should not happen. Tell me what you have in mind about this issue.

Share Your Thoughts

  • Hot
  • Active