Forum Thread: KALi Linux WIFI PROBLEM!

Hey Guys,

I am a newbie with Kali Linux I messed up my old laptop's wifi network. First of all, I use TOSHIBA Satellite with Intel Wifi Link 5100. In the beginning everything was working perfectly but when I ran airmon-ng and put my wlan0 to monitor mode, I never got it back. I tried rmmod to remove the mode and reboot it but it did not work and I tried mostly everything. The wifi symbol is in the settings and seems operating without finding any networks. After rebooting, it seems like it connects for 15 seconds and it just stays there with no connection. USB wifi adaptors work perfectly fine its just after I used airmon-ng to put wlan0 to monitor mode and recovered from it to back to managed mode it does not work. When I try to use 'ifconfig wlan0 up', I get "SIOCSIFFLAGS: INPUT/OUTPUT ERROR. " In addition to this, this KALI machine is dual booted with Windows and when I switch to Windows it does not connect to wifi and it does not see the wifi card connected to it either. PLEASE HELPP!

Get The Null Byte Newsletter

Never miss a new hacking or security guide

2 Responses

I'ts Because When You Type The Command:
1: airmon-ng start <<interface for ex: wlan0 or wlan1 ..etc>>
This Command Kill Three Important Process Or Services Show in Picture...

When You Finish From Your Attack Or What You Do Yo Must Do Three Important Commands:

Stopping the Monitor Mod

airmon-ng stop <<interface as Wlan0 Or Wlan1>>

Start/Restart Important Services

Command 1 : service NetworkManager start
Command 2 : service wpa_supplicant start

With My Best Wishes....

Yeah I realized that too late. Also I ran those commands that you stated thank you for that! But it changed nothing still my WiFi is unavailable. In addition to this, when I ran airmon-ng command I get the following;

When it states the Chipset: Intel Corporation Wifi Link 5100( rev ff) .

I dont know why it states (rev ff).

Any other suggestions?

Best regards!

Share Your Thoughts

  • Hot
  • Active