Forum Thread: How to Get Proxychains to Work?

I installed kali linux last week and started a new tutorial on Ethical hacking, Everytime I try to get proxychains to work it timesout I tried different Wi-Fi but just the same. Thats what it type for me.

proxychains firefox www.google.co.uk
ProxyChains-3.1 (http://proxychains.sf.net)
|DNS-request| detectportal.firefox.com
|D-chain|-<>-127.0.0.1:9050-<>-127.0.0.1:9050-<--denied
|D-chain|-<>-127.0.0.1:9050-<><>-4.2.2.2:53-|DNS-request| www.google.co.uk
|D-chain|-<>-127.0.0.1:9050-<>-127.0.0.1:9050-<--denied
|D-chain|-<>-127.0.0.1:9050-<><>-4.2.2.2:53-|DNS-request| self-repair.mozilla.org
|D-chain|-<>-127.0.0.1:9050-<>-127.0.0.1:9050-<--denied
|D-chain|-<>-127.0.0.1:9050-<><>-4.2.2.2:53-<--timeout
|D-chain|-<>-127.0.0.1:9050-<><>-4.2.2.2:53-<--timeout
|D-chain|-<>-127.0.0.1:9050-<><>-4.2.2.2:53-<--timeout
|D-chain|-<>-127.0.0.1:9050-<><>-4.2.2.2:53-<--timeout
|D-chain|-<>-127.0.0.1:9050-<><>-4.2.2.2:53-<--timeout
|D-chain|-<>-127.0.0.1:9050-<><>-4.2.2.2:53-<--timeout
|D-chain|-<>-127.0.0.1:9050-<><>-4.2.2.2:53-<--timeout
|DNS-response|: detectportal.firefox.com does not exist
|DNS-request| detectportal.firefox.com
|D-chain|-<>-127.0.0.1:9050-<>-127.0.0.1:9050-<--denied
|D-chain|-<>-127.0.0.1:9050-<><>-4.2.2.2:53-<--timeout
|DNS-response|: www.google.co.uk does not exist
|DNS-request| www.google.co.uk
|D-chain|-<>-127.0.0.1:9050-<>-127.0.0.1:9050-<--denied
|D-chain|-<>-127.0.0.1:9050-<><>-4.2.2.2:53-<--timeout
|DNS-response|: self-repair.mozilla.org does not exist
|DNS-request| self-repair.mozilla.org
|D-chain|-<>-127.0.0.1:9050-<>-127.0.0.1:9050-<--denied
|D-chain|-<>-127.0.0.1:9050-<><>-4.2.2.2:53-<--timeout
|D-chain|-<>-127.0.0.1:9050-<><>-4.2.2.2:53-<--timeout
|D-chain|-<>-127.0.0.1:9050-<><>-4.2.2.2:53-<--timeout
|D-chain|-<>-127.0.0.1:9050-<><>-4.2.2.2:53-<--timeout
|D-chain|-<>-127.0.0.1:9050-<><>-4.2.2.2:53-<--timeout
|D-chain|-<>-127.0.0.1:9050-<><>-4.2.2.2:53-<--timeout
|D-chain|-<>-127.0.0.1:9050-<><>-4.2.2.2:53-^A<--timeout
|DNS-response|: detectportal.firefox.com does not exist
<--timeout
|DNS-response|: www.google.co.uk does not exist
|DNS-request| support.mozilla.org
|D-chain|-<>-127.0.0.1:9050-<>-127.0.0.1:9050-<--denied
|D-chain|-<>-127.0.0.1:9050-<><>-4.2.2.2:53-|DNS-request| www.google.co.uk
|D-chain|-<>-127.0.0.1:9050-<>-127.0.0.1:9050-<--denied
|D-chain|-<>-127.0.0.1:9050-<><>-4.2.2.2:53-<--timeout
|DNS-response|: self-repair.mozilla.org does not exist

Thats The Proxychains.conf file:

# proxychains.conf VER 3.1
#
# HTTP, SOCKS4, SOCKS5 tunneling proxifier with DNS.
#

# The option below identifies how the ProxyList is treated.
# only one option should be uncommented at time,
# otherwise the last appearing option will be accepted
#
dynamic_chain
#
# Dynamic - Each connection will be done via chained proxies
# all proxies chained in the order as they appear in the list
# at least one proxy must be online to play in chain
# (dead proxies are skipped)
# otherwise EINTR is returned to the app
#
#strict_chain
#
# Strict - Each connection will be done via chained proxies
# all proxies chained in the order as they appear in the list
# all proxies must be online to play in chain
# otherwise EINTR is returned to the app
#
#random_chain
#
# Random - Each connection will be done via random proxy
# (or proxy chain, see chain_len) from the list.
# this option is good to test your IDS :)

# Make sense only if random_chain
#chain_len = 2

# Quiet mode (no output from library)
#quiet_mode

# Proxy DNS requests - no leak for DNS data
proxy_dns

# Some timeouts in milliseconds
tcpreadtime_out 15000
tcpconnecttime_out 8000

# ProxyList format
# type host port user pass
# (values separated by 'tab' or 'blank')
#
#
# Examples:
#
# socks5 192.168.67.78 1080 lamer secret
# http 192.168.89.3 8080 justu hidden
# socks4 192.168.1.49 1080
# http 192.168.39.93 8080
#
#
# proxy types: http, socks4, socks5
# ( auth types supported: "basic"-http "user/pass"-socks )
#
ProxyList
# add proxy here ...
# meanwile
# defaults set to "tor"
socks4 127.0.0.1 9050
socks5 127.0.0.1 9050

PLEASE HELP

9 Responses

# defaults set to "tor"
socks4 127.0.0.1 9050
#socks5 127.0.0.1 9050

try start tor service

apt install tor
service tor start

# I personaly prefer to run the tor program itself, as i have had issues with
# the service, if it's your case, just type "tor" in a terminal window.
------------------------------------------------------------------------------------------

Oh, and you also don't need to use "socks4", only "socks5". Leaving it that way will only make your traffic go through TOR in socks4, then go back to your machine (127.0.0.1) and use yourself as another proxy, this time through socks5, in other words, slow as fuck.

yes your method is working

DANTALION , WLAN1 Thanks for replying after researching i found out that my country banned tor traffic so i needed to configure bridges and it works now, but what is really confusing is when I use proxies instead of tor it keeps saying !!!need more proxies!!! and sometimes it works with just one proxy what does that mean

My country is blocked too andI don't know how to do these configurations and bridges can you help me ?

Try using the Network Mapper. It didn't work for me at first as it's blocked here in my country as well. Now it does.
type in proxychains nmap -sS "IP Address"
So ping whichever website you want access to and add the IP Address above
Also, make sure you edit proxychains.conf file as above and to start the tor service.
PS: This is for root user

you have to manually use a dns address

  1. open terminal with root privile

ges and type locate proxyresolv

  1. now you will get location of proxyresolv: open it with any editor like : (type in terminal) leafpad "location of proxyresolv file" : example in mine is /usr/lib/proxychains3/proxyresolv
  2. now that you have opened that file change dns address to any other name server/dns-server you like to choose for anonymity examples opendns, google etc mine is set to OpenDns server 208.67.222.222 and save the file
  3. now run proxychains you will be able to use firefox with proxychains or use any other program that requires resolving of host name.

The fix is very simple-
Uncomment #defaults set to "tor" string which means remove the number "#" symbol before defaults set to "tor". Restart

Share Your Thoughts

  • Hot
  • Active