Forum Thread: Msfconsole Error After Msfupdate

i couldn't run msfconsole after msfupdate. it give's me a error:

"Could not find i18n-0.7.0 in any of the sources"
"Run `bundle install` to install missing gems."

when i run 'bundle install', i got another error:
"Could not locate Gemfile or .bundle/ directory"

how to resolve this?

Our Best Hacking & Security Guides

New Null Byte posts — delivered straight to your inbox.

6 Responses

You might try moving to Metasploit's directories and then running this command. You'll want to be in the same directory as the file named Gemfile in the Metasploit directories.

EDIT: I found "Gemfile" under /usr/share/metaploit-framework

-Defalt

When installing on Termux, I ran in to the same problem...took me a while to solve the puzzle but in the end it was simple. I used

cd /data/data/com.termux/files/usr/opt
ls just to view the directory.

bundle install.

Worked like a gem.

I solved this error today, is a bit complicated no?

cd /usr/share/metasploit-framework/
apt-get install libsqlite3-dev
bundle install

Good luck!

i solved this error. but it took some time because of dependencies.

Hi. Would you please exactly say what steps did you take to fix it?

Share Your Thoughts

  • Hot
  • Active