Forum Thread: Metasploit Help Required

Metasploit Help Required

I was about to use Metasploit for the first time in a couple days but instead of the Metasploit loading text i was greeted by this error instead

I am on kali Linux 2016.2

/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.7.1/lib/activesupport/dependencies.rb:274:in `require': cannot load such file -- msf/core/dbmanager/import/libpcap (LoadError)

from /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.7.1/lib/active_support/dependencies.rb:274:in `block in require'

from /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.7.1/lib/activesupport/dependencies.rb:240:in `loaddependency'

from /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.7.1/lib/active_support/dependencies.rb:274:in `require'

from /usr/share/metasploit-framework/lib/msf/core/db_manager/import.rb:52:in `<module:Import>'
from /usr/share/metasploit-framework/lib/msf/core/db_manager/import.rb:15:in `<top (required)>'

from /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.7.1/lib/active_support/dependencies.rb:274:in `require'

from /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.7.1/lib/active_support/dependencies.rb:274:in `block in require'

from /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.7.1/lib/activesupport/dependencies.rb:240:in `loaddependency'

from /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.7.1/lib/active_support/dependencies.rb:274:in `require'

from /usr/share/metasploit-framework/lib/msf/core/db_manager.rb:73:in `<class:DBManager>'
from /usr/share/metasploit-framework/lib/msf/core/db_manager.rb:23:in `<top (required)>'

from /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.7.1/lib/active_support/dependencies.rb:274:in `require'

from /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.7.1/lib/active_support/dependencies.rb:274:in `block in require'

from /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.7.1/lib/activesupport/dependencies.rb:240:in `loaddependency'

from /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.7.1/lib/active_support/dependencies.rb:274:in `require'

from /usr/share/metasploit-framework/lib/msf/core/framework.rb:61:in `<class:Framework>'
from /usr/share/metasploit-framework/lib/msf/core/framework.rb:26:in `<module:Msf>'
from /usr/share/metasploit-framework/lib/msf/core/framework.rb:18:in `<top (required)>'

from /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.7.1/lib/active_support/dependencies.rb:274:in `require'

from /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.7.1/lib/active_support/dependencies.rb:274:in `block in require'

from /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.7.1/lib/activesupport/dependencies.rb:240:in `loaddependency'

from /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.7.1/lib/active_support/dependencies.rb:274:in `require'

from /usr/share/metasploit-framework/lib/msf/core.rb:46:in `<top (required)>'

from /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.7.1/lib/active_support/dependencies.rb:274:in `require'

from /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.7.1/lib/active_support/dependencies.rb:274:in `block in require'

from /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.7.1/lib/activesupport/dependencies.rb:240:in `loaddependency'

from /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.7.1/lib/active_support/dependencies.rb:274:in `require'

from /usr/share/metasploit-framework/lib/metasploit/framework.rb:25:in `<top (required)>'
from /usr/share/metasploit-framework/lib/metasploit/framework/database.rb:1:in `require'
from /usr/share/metasploit-framework/lib/metasploit/framework/database.rb:1:in `<top (required)>'
from /usr/share/metasploit-framework/lib/metasploit/framework/parsed_options/base.rb:17:in `require'
from /usr/share/metasploit-framework/lib/metasploit/framework/parsed_options/base.rb:17:in `<top (required)>'
from /usr/share/metasploit-framework/lib/metasploit/framework/parsed_options/console.rb:2:in `require'
from /usr/share/metasploit-framework/lib/metasploit/framework/parsed_options/console.rb:2:in `<top (required)>'

from /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.7.1/lib/active_support/inflector/methods.rb:263:in `require'

from /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.7.1/lib/activesupport/inflector/methods.rb:263:in `constget'

from /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.7.1/lib/active_support/inflector/methods.rb:263:in `block in constantize'

from /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.7.1/lib/active_support/inflector/methods.rb:259:in `each'

from /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.7.1/lib/active_support/inflector/methods.rb:259:in `inject'

from /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.7.1/lib/active_support/inflector/methods.rb:259:in `constantize'

from /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.7.1/lib/activesupport/coreext/string/inflections.rb:66:in `constantize'

from /usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:73:in `parsedoptionsclass'
from /usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:69:in `parsed_options'
from /usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:47:in `require_environment!'
from /usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:81:in `start'
from /usr/bin/msfconsole:48:in `<main>'

2 Responses

Hi, i dont`t know but maybe update metasploit with "msfupdate"
or with apt-get update, apt-get dist-upgrade and if it doesn´t work remove it and reinstall it?
Hope it works

for some reason my metasploit isn't in the place where the installer put it and i don't know if that will mess with some other programs or not

Share Your Thoughts

  • Hot
  • Active