Forum Thread: Kali Linux Gods/Godesses !!! PLEASE Help Me!

Hi everyone...for the love of everything somebody please help!! Im no sure if this is posted in the right area/page/etc ... and forgive me...but im so lost and frustrated...

I have kali linux installed on a laptop, I just did an expensive course, it was great, i have alot of programs i made i cant get back etc etc.. advancved users have mercy, sometimes a little knowledge is dangerous and im learning... so Best I can tell, the only 2 fatal things that happened was I was trying to run a script on startup, I was googling so many things, I may have edited something in like /systemd/system .. ?? (nothing will be very helpful, im new, advanced users may be able to figure this out and i was looking at a lot of "init" files ... init.rc ?? init.d ?? something... i have a vauge recollection whatever file it was was only present in /root ?? maybe? ... things were well (I hadnt rebooted) i did other stuff for hours, at one point the computer seemed to hang, I think it was running a program and i was (i know I know) lazy and it wouldnt give me control so i hard rebooted (I know..) , and .. maybe expectedly...it now seems to boot up, load grub, then exit to a (initramfs) prompt .... the error is:

run-init: cant't execute '/sbin/init': No such file or directory
Target filesystem doesn't have requested /sbin/init.
run-init: can't execute '/sbin/init': No such file or directory
run-init: can't execute '/etc/init': No such file or directory
run-init: can't execute '/bin/init': No such file or directory
run-init: can't execute '/bin/sh': No such file or directory
run-init: can't execute '': No such file or directory
No init found. Try passing init= bootarg.

BusyBox v1.30.1 (Debian 1:1.30.1-4) built-in shell (ash)
Enter 'help' for a list of built-in commands.

(initramfs)

Then im stuck at this prompt. If it enter 'exit' ...

Then it continues with Kernel panic - not syncing: Attempted to kill init! exitcode=0x00000100

etc....

I have been looking online for answers for days now, I have tried fsck, I have booted from live usb and run the gparted check on the volume,

I am so lost and frustrated and have no idea what to do or where to go next, ive watched every youtube i can find ...

Im almost at the point of having to reinstall, and I realllt really really dont want to loose all my coursework that took me weeks, ill never do it all again.

Superman (or woman) if your up there...please help! or email operationsiphone1701@hotmail.com

Never Miss a Hacking or Security Guide

Get new Null Byte guides every week.

4 Responses

So just to add any more info I can, the sbin/init files are indeed there, I tripped across something about booting live USB, then mounting my sda1 and running apt-get install init...and somehow that feels right but when I attempt to run chroot/mnt it gives me an error about something like "chroot command not found /bin/bash " kinda thing, and (I'm a super noob, take that into full account here) so I tried running apt-get reinstall init from /mint/root but I get the feeling it's just reinstalling init on the live USB without the chroot command working?

I've seen a lot too about in the grub config setting the "root=" to different stuff, and arguably mine looks different, but I changed it to match a few and grub keeled over and died until I changed it back. I also get that feeling, and other people mention "change sdb to sda " somewhere (I imagine on the Linux line) but nowhere in mine does it mention either ever

Silently waiting in reverence for the Linux gods(esses) to arrive.... (ohmmmmmmm)

well, i cant wit with a machine that cant boot any longer. I wish I was one of those lucky people who get tons (any) replies from expert peoples who were like"hmm...try typing this.,.." and i got to be one of those peoples that were like thank you now i dont have to lose all my data" ...

too bad

down vote
accepted

As we can see in the messages you get, the most possible cause is a permission issue. Also it seems that /sbin/init and /etc/init exist but /bin/init does not.

Get rid of /bin/sh: 0: Can't open splash

First we should get a shell to fix the problem. To get rid of /bin/sh: 0: Can't open splash and get a shell: If you only have an Ubuntu installed (GRUB will not appear by default), while the system is booting hold the shift key to make GRUB appear. Then on the default menu press E.

You will find a line starting with Linux. At that line remove the splash parameter and then press Ctrl+x, now you will be dropped into a sh shell. Run /bin/bash to get a bash shell if you want to. I prefer bash over sh because it has auto-complete functionality.

Alternatively instead of removing splash parameter, you can add init=/bin/bash at the end of that line and then press Ctrl+x; this time we'll be dropped into bash instead of sh.

Fix the run-init: /sbin/init: Permission denied
Run:

ls -lH /sbin/init
It should produce something like:

-rw-r--r-- 1 root root 1577000 Feb 15 12:20 /sbin/init

As we can see permissions are messed up. in almost all systems these days /sbin/init is a link to systemd, just to make sure:

# ls -l /sbin/init
-rw-r--r-- 1 root root 1577000 Feb 15 12:20 /sbin/init -> /lib/systemd/systemd
Sure it is, your / (root) file system is mounted in ro state (Read only), lets change it to rw (Read and write):

# mount -o remount,rw /
Then fix the permissions:

# chmod u=rwx,g=rx,o=rx /lib/systemd/systemd
Reboot the system.

Credits- stackoverflow

Share Your Thoughts

  • Hot
  • Active