Forum Thread: Guys Need Help Installing Kali Linux 1.0.9a in VMware Workstation 11

Hi there I am fairly new to kali Linux but I have encountered a slight problem while I was watching a video on how to install everything went fine until installing the system... it says failed to install the system looked through forums and stuff but nothing..

  1. downloaded from official kali Linux site
  2. I have 64 bit comp
  3. downloaded 1.0.9a 64bit iso (via torrent)
  4. using VMware workstation 11

Please reply to this really appreciate it.

34 Responses

Errors like these can have multiple causes. Just to start troubleshooting:
-Which VM options did you choose during the VM setup?
-Which steps does the tutorial run trough?
-Are you sure you are using 64 bits every where?

What do you mean 64bits everywhere can you give me example?

64 bit Kali VM on 64 bit Virtualbox for 64 bit widows using the correct 64 bit options.

Dear Jhon

This can have several problems. How many GB's of data are you letting VMWare have? You should have atleast 50GB's to be able to run Metasploit and let it all load, because 10GB's is very little for Kali Linux.

But, if the error happens, there should be something like saying "System Installation failed" There should be something at the end which looks like "Debug", it'll give u an URL, put that URL into your URL and check what is the problem. The most common is not enough GB's.

Kind regards,

Ragin' Hacktivist

Believe me, even 15 GBs are too many but recommended. With 50 GBs of VM you are going very high!
However, he's right, main reason is usually not enough space or RAM.

Dear Ciuffy,

If you are planning on being a hacktivist, installing a lot of things on Kali Linux, it is well recommended to use 50GBs. I know a hacktivist that uses 100GB's because it is well needed if you are installing a lot of stuff in Kali Linux. Kali Linux in less than the first 1Hour took me 10GBs.

Yep, but at that point, you just don't use a Virtual Machine. As you can see, on Null Byte we talk most about Live installation of Kali Linux with pre-installed tools (most of, but there's a lot of different stuff here).

I don't doubt that hacktivists have lots of tools (at the end, if Kali becomes your main OS, I mean every main OS has that amount of used space, if the user likes to play with different programs), but you will agree with me that if you are already running a OS, using a USB installation or dual-boot is better than taking those 50 ones to the OS in use. Actually on my Arch, I'm good with 8 GB of USB persistence, so you see it really depends on who is using it. I was just supposing that a VM is for lab tests.

But what's the difference between dual boot and USB boot? And live amd64 didn't save the work as I had a password list for air crack saved on my desktop then next time I booted or it was gone?

-The difference between USB boot and dual boot is that with USB boot you boot from USB, with dual boot you boot directly from your Hard Disk, as you install Kali and the boot loader on a partition of the HD.

-It didn't save the changes because you Live Booted. It is supposed to work like that. If you are using a USB, you can add the persistence option to save your changes, more here.

I am not quite sure how to read logs is it ok if I put on a txt file and someone help me see what's wrong please? And also how is this possible have needing 50gb of space when most set iOS tuts say at least 20gb?

Well, if you actually have a log, you should try to provide it to us (sounds strange, but I don't know). Is it too long to post?

However, you should first provide us the options you chose during the setup.

ok so here are the steps I took (try and find a faulty area if possible thanks)

  1. Typical installation
  2. iso located (debian 7.x 64-bit detected)
  3. named my virtual machine kali linux
  4. maximum disk space recommended 20gb but as you guys said maybe 50 so I did that and store virtual disk as a single drive.
  5. customize hardware and allocated 1gb memory, network adapter is bridged.
  6. then I booted the machine
  7. went on graphical install
  8. English, new Zealand, American english
  9. hostname (left as default)
  10. domain name blank
  11. password toor
  12. Auckland for the clock
  13. guided use entire disk
  14. SCSI3 (0,0,0) (sda) - 53.7 GB VMware, VMware Virtual S
  15. all files in one partition
  16. finish portioning and write changes to disk
  17. write changes to disk (yes)
  18. then it installs the system
  19. around about now this is where things muck up around the 80% mark
  20. it says " an installation step failed. you can try run the failing item again from the menu, or skip it and choose something else. The failing step is: install the system.
  21. so then I go on menu and press debug and will post the logs. thanks

Ok sure thing! THANK YOU EVERYBODY WHO HELPED WITH MY PROBLEM APPRECIATEd

WHAT LOGS DO YOU GUYS WANT?
•Xorg.0.log
•hardware-summary
•partman
•syslog

Hi, off the top of me head:
Do you have enuff space for the install?
Have you just tried to use the Live DVD to test if your machine even works?
Have you tried a 32bit Kali to see if it works in your VM?
Have you tried a USB Persistent install?
Did you try and download a new copy of the Kali ISO? The one you have may be bad.?

i have allocated 50gb for space and 1gb for memory I have tried live amd64 install boots up fine and you can use right away :D, no I actually havn't tried the 32bit on my 64 might do that, no havnt tried usb install and yes I have downloaded multiple times before but same result and the md5 or the sham1sum is the same as the websites.

Does your physical CPU support VT-x ?
Try the 32bit . see what happens, let us know.

what's vt-x? and how do you know if it does (how do you check?)

Dear Jhon,

If you are using a VMWare Workstation, you can download a 32Bit and 64Bit one, it doesn't matter. ShellOS is only 32Bit, but since you use a VMWare, it doesn't matter. So, maybe Cyber's theorie might work. Give us feedback!

Kind regards,

Ragin' Hacktivist

Do you want to see any logs before I install the 32bit version?
•Xorg.0.log
•hardware-summary
•partman
•syslog

those are the logs I can provide you guys with

But doesn't 64bit work only on 64bit computers?

Dear Jhon,

The 64bit works with ANY TYPE OF COMPUTER, aslong as VMWare is running it. As I said, ShellOS is only 32Bit but since VMWare is a virtualbox, it can run on any system. Aslong as your VMWare is running, it's all okay.

Kind regards,

Ragin' Hacktivist

ok thank you very much I am currently downloading kali Linux 32bit and will try to install on VMware I will keep u updated with it :D

Ok so I just finished installing kali Linux graphical install 32bit and it worked somehow it got past the installing the system but why couldn't my 64bit do that? but right now its hanging on "configure the package manager and its on a white screen... is it supposed to do that?

Because the CPU does not support Vt-x or AMD-v regardless of the architecture . So 64 bit VM >> 64 bit OS with non 64 bit VT-x CPU makes a difference?

The slow configure may be from sources file.

ah i see thanks :D I have finished setting up everything I just need to install the guest additions on kali im up to the part where it has to download the updates but it keeps saying 0% im guessing you need a wireless adapter for this part? I have a tp link WN722N adapter ok or no?

As always, Cyber saves the day.
Oh no, not again, the internet part! I definitely have to update my guide on this...

Up in the right corner, in the wi-fi menu, does it say it is correctly connected to the internet via ethernet, or something like "device not managed"?

Oh, and if you have a wireless adapter you can just plug it in and (quoting from my older post):

"You have to first disconnect it from the host and the connect to the VM, because you are running under a Virtual Machine.

Try:

Top_Menu>VM>removable_devices>your_wireless_adapter->connect (Disconnect from host).

While the Virtual Machine is running.
Wait for 10 seconds for Kali to recognize it and then connect.
If it doesn't work, maybe there's some compatibility issue."
And your Kali gets internet access, if the wireless adapter is compatible.

Thanks you very much guys I will keep u guys updated with everything :D

Dear Jhon,

I hope it went well. And the 64Bit might not work because the download didn't download completely. Anyways, aslong as your on VMWare, everything should sail fine with the 32Bit version, just don't go and install it on the entire system or some bad crap might happend.

Kind regards,

Ragin' Hacktivist

will anybody help me. I have installed kali linux two times in my laptop but, when I am using it freezes randomly. I tried different linux. no such problem occurred ever... except this...

with kali 1.1.0a....
I have searched most and did as much I could... like re installation, checking broken packages...
verifying the package... and other installations...
will previous versions of kali will solve this....
please tell me .... as soon as possible.

Your Guest OS will not get connected once your host got connected, Unless you have configured your VM's Network settings. Moreover No need to power off other virtual machines in order to gain access for your Kali. I have VMWare 11 installed on my windows 8.1 64 bit platform and I work with multiple OS es at the same time all connected to the internet and working properly.

VMWare has the following network settings. . .

1) Bridged,

2) NAT,

3) Host Only,

4) Custom

NAT will be the default selection. I was running XP SP3 and Kali at the same time and couldn't establish a connection. So what I did is, I just changed the setting from NAT to Bridged. But then XP got connected and said limited connection(You can't use your net connection when limited).

I tried all other option which were ineffective and the came back to bridged. In bridged connection select the Replicate physical network connection state. This worked perfect for my Win XP.

But still Kali was keeping on reconnecting for the same setting. For Kali I chose Custom: Specific Virtual Network. In custom I chose VMnet0(bridged) option. Then I went to Edit --->Virtual Network Editor.

When it opened, in the bridged option I chose my network adapter (mine is Realtek PCIe) (you choose your network adapter). Voila now I have no problem at all. now I have a stable connection. I am running Windows XP SP3, 7, 8, Server and Kali without any problem in my network connection.

Share Your Thoughts

  • Hot
  • Active