Forum Thread: Kali Linux Help

Kali Linux Help

I recently downloaded Kali Linux from Offensive Security and installed it into Virtual Box. I had specifically chosen the 64 bit version as I had assumed my Windows 7 OS with an Intel Core i3 was 64 bit, though upon configuring the General settings all the Linux operating systems listed came out as 32 bit, though I had checked earlier that I did indeed install the 64 bit version from the website.

It seemed to work fine at first, as I made it to the Boot Up menu of Kali and chose Install, however the process never works because the Boot menu keeps giving me a message stating:

This kernel requires an x86-64 CPU, but only detected an i686 CPU.
Unable to boot - please use kernel appropriate for your CPU.

Under System Settings of Virtual Box I noticed under the Processor tab that the CPU was locked at 1 and I had no access to the Acceleration tab. I tried looking through for a solution on Youtube, where some tutorials suggested PAE/NX might help, though in my case it didn't change the CPU error.

Could anyone here please help me with this issue, as I really wish to be able to use Kali.

5 Responses

First retry the process as described in the link.
If you get the error again, try and install the 32 bit version.

If that doesn't work, you should try to enable Intel Virtualization Technology from BIOS. here's more about this.

If you solve this, please report the solution.

I've been browsing through Linux and Kali forums but it appears no one has encountered this error, as I can't find details to fix it anywhere.

I'm assuming my PC probably does have this x86-64 CPU operational but probably not detectable by the guest system on Virtual Box.

I already reinstalled Kali Linux earlier when my first attempt to boot it into Virtual Box failed, yet I'm not sure how my second attempt almost succeeded. I've finally come so close at using Kali but now am indefinitely halted thanks to this strange error. With no solutions available to fix this kernel issue I suppose the only real option I have is to remove, delete and reinstall the Kali ISO for the third time.

Ciuffy is correct this is a common issue. Your CPU is the issue. Use 32 bit ISO.

Share Your Thoughts

  • Hot
  • Active