Forum Thread: Problem with Wireless Adapter in Kali VM

Problem with Wireless Adapter in Kali VM

Hi everyone.

This is my first post here in null-byte, though I've been exploring it in the past months, getting to know the basics and some quick exploitation tips hehe. Very very cool site

Well I installed a virtual guest of kali linux in virtual box with an image specific for virtual box. I've fixed the repositorys folder and got update and upgrade etc. My problem rises when I try to get a wireless interface.

One of the first posts I read was the one on linux instalations (linux ultimate portability guide or something similar), and it said I would need a wireless adapter in order to get a wireless interface in a virtual guest. So I bought an alpha adapter following the recommendations from OTW's post on the subject - thanks for all the work you putted in this site btw, making computer security knowledge more accessible to people like me. But once I plug in the wireless adapter, and try to enable it using the devices tab in the box, the box freezes. I'm incapable of shuting it down, even when I end the virtual box tasks in task manager, once I start Virtualbox again it just says the box is shutting down.

I've been trying to fix this for the last couple of days, and I thought that maybe one of you would know if I'm doing something wrong, or maybe point me in the right direction.

Thanks in advance, and again thank you for the awesome site.

18 Responses

Greetings CYBERHITCHHIKER. That was the post I've followed in all my kali instalations (my bible per say haha). I tried doing what Ciuffy said: I went to devices->USB devices and clicked on my wireless adapter to mount it. That's when the box stops responding...

i had problems with virtualbox too.. just quit on it and go VMware

Agreed. VMWare is the best choice if ya ask me..

Quote.
Maybe give some specifics? I may add this to the guide, thanks!

Ciuffy what type of specifics would you like to have for the tutorial?

Os, versions...

I have the latest version of virtual box (4.3.28). For the OS (some of you might grind your teeth) I'm testing out windows 10 technical preview lol.

VB latest version has issues like others have said and myself. Downgrade it.

Why do you say VMWare is the best choice? Is it because it gives less problems than virtual box or is there more to it?

You could Live Boot from a USB Stick with Persistence to get the adapter working without messing with a virtual PC or your PC :)

I have done that kitten but I found that sometimes is more efficient to have kali running in a virtual machine, instead of having to restart my system and boot it from a usb drive.

The "docker" choice just came out... gotta write something about it...

I have to take a look into that when I have more time

Okay, okay. I know about this issue. Here is a great video that worked good for me. It involves turning on your wireless adapter in the settings of virtual box before booting it.

Check the video here:

I tried to use the fix of that video but it didn't work for me. I think I'll just go to vmware and test it out

A quick google search of your issue does show multiple versions of virtualbox having this issue with multiple OS versions. Solutions ranged from uninstalling and reinstalling drivers to upgrading and/or down grading versions.

hello kali lovers, i fixed this issue. i also faced problem after installing

kali in virtual box, that it did not show wlan0 interface but now it is

showing. i just followed this video .you must watch it

Share Your Thoughts

  • Hot
  • Active