Forum Thread: How to Fix 'Failed to Detect and Mount CD-ROM' Problem When Installing Kali Linux

This guide will help you fix failed to detect and mount CD-ROM problem when installing the latest edition of Kali Linux.

Although there are other guides that exist, I found that the solutions in those guides still did not work when I used the Universal USB Installer to create the bootable USB. After messing with it all weekend, I finally found that if I used Rufus instead, the process worked. I decided to write a post on here so it would pop up on the first page of a google search so people wouldn't have to go through a bunch of crap to find a fix.

Step 1: Use Rufus to Create Your Bootable Kali USB

For this to work, you must use Rufus to create your bootable Kali USB. You can download it here: rufus.akeo.ie . When prompted, select 'DD Image Mode'. Using 'ISO Image Mode' will not work!!

Step 2: Detect and Mount CD-ROM

a. When you get to this point where it says 'your installation CD-Rom couldn't be mounted, unplug the USB from your computer drive and wait 30 seconds before plugging it back in.

b. After plugging the USB back into the drive, wait another 30 seconds then click 'yes' to retry mounting the CD-ROM

Step 3: Missing Firmware

During installation you may get a message that indicates you're missing firmware or some other package, I typically just ignore them and continue on with the installation. I've never had any issues. But if you're insist....

When you get to the part where it notifies you that you're missing firmware, visit the following link and download it onto a different USB device. packages.debian.org/wheezy/all/firmware-realtek/download.

(Kali Linux is based on Debian Wheezy)
Choose which ever mirror closest to you

Step 4: Install Missing Firmware

Insert the USB you just downloaded the missing firmware onto into the computer you're installing Kali on. Wait 30 seconds before clicking 'yes' to install the firmware from a removable device.

Step 5: Continue with Installation

You should have no further issues.

Get The Null Byte Newsletter

Never miss a new hacking or security guide

10 Responses

what if i dont have another removable device?

You only have one flashdrive? If that's the case, skip the part about installing the firmware and continue with the install. I've had to do it that way before too. Preferably you want that firmware installed I'm assuming.

You can download the firmware missing using the link, then put the downloaded firmware into the firmware folder in the boot bootable Kali in your pen drive or SD card then try installing the Kali Linux

Unplugging and pluggng it back isn't working.
Any other ways!

The better think is use Rufus and use
dd image to create bootable media done

All the way does not work for me.
Is it because my laptop does not have a cdrom?
Does it matter?
Pls answer.

For those using Windows 10, make sure to be in windows logged in, hold shift down and and then navigate to power>restartPC. This will bring up the UEFI boot menu, go to advance options and select the UEFI option. Your pc will reboot to Bios, make sure full USB support is enabled instead of partial under boot options, click save settings and reboot after setting the boot priority to only your USB.

yes

Thank You for this!!!! I have been wondering why my images were not working , and out of ALL the solutions I looked at, like the popular (mount -t vfat /dev/sdb1 /cdrom) which never worked, I was convinced that there was something wrong with my imaging process and you found it " in rufus USE DD not ISO" and honestly I am kinda ashamed that I was moving so fast that I let that slip by me,,well, I did it and it Worked! I don't understand why this isn't talked about more!!

THIS WORKS!
THIS WORKS!
THIS WORKS!

Share Your Thoughts

  • Hot
  • Active