Forum Thread: Kali Xrdp

Kali Xrdp

I'm trying to setup xrdp in Kali to RDP from Win 7. I've tried the following on a Live Persistence USB and a full local install but the result is the same each time :(

#sudo apt-get install xrdp
#service xrdp start
#service --status-all //to check the service is running which it is

I then RDP in from Windows and what I end up with is a weird looking blank screen for a few seconds then an error saying that something has gone wrong and I need to log out. It would appear as far as windows in concerned that I have made it to Kali and am logged in. Albeit briefly.

It's really frying my brain, can anyone help. The only constant I can see here is that it's happening with my live usb and with a full install on a desktop too.

Edit:

Pulling hair out now! Tried on two other Windows machines and result is the same. It's breaking me!

I should also add that after the logout I'm not logged out of the rdp session as such but I'm just taken back to the same weird blank screen (what looks like really small black and white lines)

Also I've noticed that I have to:

#sudo apt-get install xrdp
#service xrdp start

Each to I reboot/startup too.

1 Response

Share Your Thoughts

  • Hot
  • Active