Forum Thread: Kali Wont Start, Stuck at Kali Login:

Hello everyone, I'm very happy to join this community I'm a debian user. I've got an HP mini 200 i want to install kali as only distro on it. so I've make the installation through usb. but my installation won't start and stuck at the last process. with the mention:

Kali GNU/Linux Rolling kali tty1
kali login:

and the mouse's cursor moving between up left corner of the screen and the middle.

I've tried so many thing but nothing worked. some ideas to help me?

For info,I can launch the live mode without problem, from the same USB storage.

Join the Next Reality AR Community

Get the latest in AR — delivered straight to your inbox.

21 Responses

This will bring to the CLI screen. Login with your credentials. Make sure you are connected to the internet (wired)
Then type :
"apt-get install x-window-system"
once that is done type:

I did it, it downloaded some files, now what to do, pls tell.

Does this procedure work for Kali 2020.1?

I was in internet connection, how can I connect to internet now

Step 1:

Thanks Vapour i will try this when coming home. but i had try some alt.ctrl.f2 thinking i cant acces something with it. probably in recovrry mode. i will told you the result.

I did the same thing you're trying to do except with my Windows 7 machine. I was able to successfully replace it with Kali Linux. I've ran into your issue before. What I had to do is completely start all over, i.e. redownload the Kali Linux iso and the installer you're using to create the USB. As a refresher, follow these steps:

Download the Universal USB Installer

Then visit the following link and download the appropriate Kali ISO.

After Kali is finished downloading, run Universal USB Installer and chose 'Kali Linux' from the list of Linux Distributions. Click 'browse' to navigate to the Kali Linux iso you just downloaded. Indicate what drive your USB is connected to and click 'create'.

When changing my operating system from Windows to Linux, I came across many many issues but I was always able to solve them by simply starting over from the very beginning with a fresh download of the iso. I'm sure there are other ways to go about it, but I found this to be the easiest rather than posting to a forum waiting, hoping someone responds, or searching the Internet endlessly for an answer.

thanks for answer. i already done so much try. reinstalling ect. as said I done the Vapour tips in recovery mode. it's working but when i reboot it's doing the same.

(sorry english is not my native language)

no problem, I can understand what you're saying. Did you re-download everything before you tried reinstalling it?

Are u trying to Dual boot with Windows ???All bcoz I am using Kali 2016(Rolling) alongside Windows 10

Did you install graphical install?
It sounds like to me you installed terminal version or something.

thts not a big deal :))

it's for a dedicated kali comp. not dual boot. and nothing from what i had tryied work. the startx method work but without network and if i reboot, it stuck at the same issue.

Hey RONIN first of tell me do u wanna use it in Dual-boot mode ...??

hey as said. not for dual boot. as main distro on an hp mini 200.

U installing it in UEFI or Legacy mode??

While at the login screen press Ctrl+Alt+F1 or Ctrl+Alt+F2 to open terminal
after that type the username and password in terminal.

Now follow commands as below
1 -sudo apt-get update
2 -sudo apt-get upgrade
3 -dpkg --configure -a
4 -sudo apt-get install cinnamon-control-center-data
5 -gdm3 --version
6 - apt-get --reinstall install gdm3
7 -apt-get --reinstall install gnome
8 - apt-get --reinstall install gnome-shell
9 -dpkg-reconfigure gdm3
10 -reboot

Thanks brother you saved my last year project

After i use ctrl + alt + F2 it say enter kali login an when i type it , shows ???? somthing like these. And after that i enter my password but it show login failed and its seemslike i am dont even typing .?

What should i do?

Click all F keys one by one till CLI starts

Log in with user name and password

Then Run following command

~ service gdm3 restart

On the spot Or after Some secs you'll be able to see the UI

If that happens restart the machine.

If above won't works execute following commands

apt-get update
apt-get upgrade
apt-get --reinstall install gdm3
apt-get --reinstall install gnome
apt-get --reinstall install gnome-shell
dpkg-reconfigure gdm3 / / select gdm3 from selections
Service restart gdm3

I've suffered in this problem too.....

Try Installing gdm3 then use it instead of sddm....
I found that it solved most of the people's problem out there....
But for me the case was different...
I was suffering because of my nvidia graphics
card driver missing....
So make sure that your graphics drivers are installed properly.....
If not then try installing it using teletypewriter......
It may help you to solve the problem....

N.B: Your pc may freeze randomly in GUI if you don't install your graphics card drivers or update them......

Share Your Thoughts

  • Hot
  • Active