Forum Thread: (Sory for Bad English )

(Sory for Bad English )

hi,

I have a problem: I tried all hacks "reversetcp" that can take control of a remote PC but it does not work, let me explain:

When I put everything and I type "exploit"; it gets stuck on "* Started reverse handler on 192.168.77.128:443
* Starting the payload handler .. "

It Does not-have Any responds

Of course, I have all followed exactly

This is a hack local network, so I have put my private IP, disabled any firewall and antivirus on PC 2 (attacker and victim). I tried with the vulnerability of MS office 2007 on windows 7, word 2010, adobe reader 9, I even tried it with an .exe but none work.

it never answers when I open the file on another PC.

what should I do?

thank you ...

15 Responses

Also , i'm on ubuntu 14.10 and have a dynamic IP .

If you are attacking windows 7, meterpreter is the good one.

I've given a fast look at the tutorial and it seems pretty easy, so I'd suggest you to post what you do step by step as precise as you can, we might be able to help you, because there's a lot of things that can cause your problem.

Provide an accurate description and make sure you are both on the same LAN, I know it's kinda obvious but when something doesn't work, you should first turn the power on, you never know.

Possible problems:
-As Cracker said, check the port.
-Always check the IPs (however the screenshot tells they are correct).

-Do you have the notepad.exe in your desktop as the how-to explains? In case you didn't understand how the hack works (I guess you did), metasploit injects a payload in the target program and once deployed and ran in windows, it connects back to the attacker and you get the meterpreter shell. It doesn't really matter which program you are injecting the payload into.

I know you've done everything correct and that probably these above are not the problems, we'll try to understand what causes the problem.

As you can see on the screenshot , i did every thing as said in the tuto.

Sorry, but you'll agree with me that if this doesn't work, there's something, probably not about what you've done, that at least conflicts.

I can advice you something as trying to run a live boot of Ubuntu instead of VM if you are using it (notice the tutorial uses Backtrack while you said you are using ubuntu, I don't know if there's any compatibility issue, but Backtrack, or better Kali, has IMO a better setup for this kind of things), or else...

Maybe someone with more experience will be able to help you with the information you gave us,in the meanwhile I'll be doing some tests with windows 7 and Kali using the guide you posted, and I'm going to post the results.

i'm using a live Ubunto and not VM, i think i will try with the windows version of metasploit or with kali .
Thanks you for your help

I found an alternative for the meterpreter to remotely control a PC : " DarkComet Rat " , do you know it? is it better?

Hey, first, just one thing, can you ping the Ubuntu box from windows 7? The problem might be just because of the setup.

how to " ping " ?

windows 7: open CMD-> type:
ping HOST
where host is the IP of Ubuntu.

If the output says the packets can be routed, then you can, which means the two computers can communicate and the problem is somewhere else.

The ping worked well.

It finally worked with another PC , thanks for your help.

Glad I could help you somehow, but I suggest you to try to understand why it didn't work in future.

Hey I was just having the same problem and i realised what was wrong, the postgresql gets disconnected from msf, to fix it, open up another Terminal and type: service postgresql start

you can check the database status in msf by typing db_status
hope that helps_
EDIT: okay nvm it didnt work -_-

Share Your Thoughts

  • Hot
  • Active