Forum Thread: Kali Linux Boot Error

Hey Sup hackers,

  1. I installed kali Linux (Linux kali 5.2.0-kalu2-amd64 #1 SMP Debian 5.2.9kali1 (2019-0822) x86_64 GNU/Linux) on live usb persistence mode as per the guidelines given on kali documentation.
  2. Then updated and upgraded with following command:

apt-get update
apt-get upgrade

  1. Issued folycommand to install tor service

apt-get install tor -y

  1. Rebooted the system to get the following error

Sorry for image quality...had no option but to click it with phone camera.

Tried rebooting but getting the same error again.
Cursor isn't available to type anything . Tried ctrl+alt+F3 but to no rescue.
Also read through various forums on internet but to no use.
Help out please.

8 Responses

Please help , I am a newbie and starting the learning curve

What OS is installed on your Dell N5110?

It's windows 10...however I am booing it from kali bootable flash drive. Windows is working fine. This flash drive was working fine a week back and no errors were there while booting kali. Suddenly it started showing this error. Formatted flash drive and re installed kali. It booted fine. On thired boot , it started showing this error. Formatted again , but the error persists

Also , I am able to boot live usb without persistence but when going in with option of with persistence, it gives the described error

Assuming your USB flash drive is at least 8Gb, just use Balena Etcher to flash the live image.
Make sure you're using either one of the latest Live ISOs the ones you've quoted don't seem right:- for 64 bit
or for 32 bit
Once booted make sure you've root privileges
#sudo su

And follow instructions from 0x02 - Create and format an additional partition on the USB stick

When you've completed reboot and then
#sudo apt-get update && sudo apt-get upgrade

Install as root any applications not already on Kali-Live last.
#sudo apt-get install (application)

Whilst you're looking at TOR, familiarise yourself with proxy chains. There's tutorials on here and youtube.

Help appreciated.
Usb stick -32 gb sandisk
I am using Power ISO to burn the image to Usb stick. And subsequently using mini partition to create the partition.

I am able to boot live without any problems however , persistence boot after following the procedure gives the mentioned error.

Any suggestions as to why this error only on persistence boot and how to mitigate it .

So I've just run through creating a new kali live usb (AMD64.ISO). Followed the instructions as above and haven't experienced any issues, apart from encryption slowing things on boot. I use Balena Etcher...never paid for a usb flashing app before and it's always worked for me across multiple OS.

I suspect your issue is to do with creating the persistent partition and over writing the live USB's existing partitions.

Re-flash the latest kali live iso to your USB and boot, you can choose the "with persistence" mode at this stage, it will work but you haven't created a persistent partition yet.

Open a terminal/from the command line >sudo su (Kali doesn't default to root on boot)

Setting the start (and end) of your new persistence partition is critical when you create it. Your commands should go something like this.

>(parted) print devices
>(parted) select /dev/sdb
>(parted) print

At this point you should get a partition table with two primary partitions listed as 1 and 2, one of which is a boot partition. Reading across the table look at the end number (it'll be something in the 3,000MBs') for the non-boot partition.

So in my case the table had an end number of 3021MB it might be different for you depending on the ISO you're using. Use this number to tell parted where the start of your new partition will begin. 10000 is where I've chosen to end the new partition to create approximately a 7Gb partition e.g.

>(parted) mkpart primary 3021 10000

Follow the rest of the instructions given at to complete.

When you reboot, from a terminal rerun > parted print devices, select /dev/sdb, print, and you ought to see your new partition listed as 3 starting at (in my case) 3021MB and ending at 10.0Gb as a type primary.

Hope this helps.

I have run into a very similar issue after updating kali 5.6.0 to kali 5.10.0.

I have a virtual network lab environment. (college project, no physical access, only way to have a fresh OS is to reset every device in the network and reconfigure which I've done once and would rather not do again)

I have a pfsense 2.4.5 firewall configured for DHCP. Kali workstation is attached to the LAN. I enabled DHCP in the GUI and tested to confirm connectivity.

Open Terminal and Run:
sudo apt update
sudo apt upgrade
y to confirm
runs what seems to be a successful upgrade
Message box (yes/no) appears saying something about moving the root folder

1st attempt: yes -> unable to mount the root error on restart, cannot boot, no cli, nothing -> had the lab reset

2nd attempt: no -> unable to mount the root error on restart, cannot boot, no cli, nothing (stuck here)

The only thing I've been able to do is the advanced boot option to choose a different kernel. Choose Kali 5.6.0 (next version available) get the error "kali kernel panic not syncing vfs unable to mount root fs on unknown-block (0 0)" in addition a mention of the sulogin(8) man page was all the information I can obtain on boot attempt. After researching for a couple hours, I can't figure out why the update breaks the system, where the root folder moves to or how it "locks", how to upgrade the system and still be able to boot the OS.

Any thoughts would be greatly appreciated!!

Share Your Thoughts

  • Hot
  • Active