Forum Thread: Having Problem Setting Up Network for Hacking with Kali Linux in VirtualBox.

Having Problem Setting Up Network for Hacking with Kali Linux in VirtualBox.

I just downloaded VirtualBox and installed Kali Linux 2 in it. I set the network setting in VirtualBox to bridged network. My virtual machine now has an ip as 192.168.XXX.XXX just like the host and the other devices in the network. I can ping the devices in my network from kali machine but i can't access the internet. When I use BeEF Framework and generate the hook address , I can access the url from my host machine but the other devices like my phone cannot access that url.

Can anyone tell me why is this happening and is there any solution to this?

2 Responses

Your IP that starts with 192.168. is your private IP. Your phone is not on your local network (unless you have it connected to WiFi), so you can't use your private IP.

As for VirtualBox, you are using Bridged Adapter? I am doing that, but I have experienced similar problems before. I don't remember how I fixed it, but try the Host-Only Adapter.

Hope I could help.

My phone is on my wifi network and host only also does not work I have tried all possible combinations of networks but I still can't make it work.

And thank you for trying to help....

Share Your Thoughts

  • Hot
  • Active