Forum Thread: Port Forwarding Help Needed Please

Port Forwarding Help Needed Please

I can not get port forwarding on my computer for the life of me. I've followed the directions for my ASUS RT-N56U router and have provided a screen shot. An NMAP scan confirms that the ports did not open. My OS is Debian Wheezy. Thanks for any help you can provide.

6 Responses

I tried it and it still won't work. I even tried disabeling my firewall. So much is pointless if I can't port forward.

You are not giving enough details, the router port forwarding would forward ports 1000 to 3000 from 2?.?.?.? to 192.168.1.100. If the ports on 192.168.1.100 are closed the forwarding would be working as expected.

ok I'm sorry, I don't understand what you mean. I ran an nmap scan against both my public and private ip and the scan shows all ports are closed. What other information should I provide for you to help me out?

Maybe this detail you don't get...

If you forward a port from computer a to computer b and computer b has that port closed then computer a will also have that port closed.

What you should do is forward to an open port on your private computer and then probe that port on the public computer to see if the port forwarding is working. (choose a port that is not open of the public computer).

I need to research it more because I'm confused. So I put up a wordpress v 3.5 website up locally using xampp. I'm using this exploit called XXS2SHELL. When I trigger the payload from my other computer it begins executing but I can't establish a connection to the shell because, I'm assuming, I'm not properly port forwarding or what ever. So I thought the point of me port forwarding was to allow the communication sent from wordpress is allowed through my router. Thank for your help.

Share Your Thoughts

  • Hot
  • Active