Forum Thread: Kali Virtual Box Load Error

Kali Virtual Box Load Error

when i load kali from Oracle VirtualBox, I get an error message saying unable to load module R3... . I had kali installed on VirtualBox, and I was practicing basics with it. Can someone help me with this? the screesnshot is below

19 Responses

excuse me, can you be a little bit more specific? cuz I'm really confused here.

It looks like sensitive VirtualBox files have been deleted...
Try and follow the guide Cyber linked above, and report if the error isn't solved.

Well, I tried uninstalling VirtualBox and then re-installing it, but it didn't solve the problem. Then I tried installing an older version, but it gave me the same result. If sensitive files have been deleted, what should I do next?

In that case, it doesn't matter anymore.
I guess there's just something wrong in the way you create the virtual machine. Follow the guide and then report.

I followed it again, but it gave me an error to restart the machine. After I restart, I got the unable to load R3 module error message again.

A quick Google search of your error shows this is a known bug in virtual box. What version are you running? Can you run any other VM's on it?

I have currently installed Kali Linux only. and I'm using VirtualBox 4.3.24 edition.

The issue seems to affect multiple versions of VirtualBox running on windows XP and windows 7 32 and 64 bit. There are a lot of complaints online.

Just curious, if you follow the path C:\Program Files\Oracle\VirtualBox\ do you see the VboxCD.dll?

One report indicated antivirus could be interfering. Also, I don't know exactly what this dll is for but its called VBoxCD.dll. Try removing the cd device. You will have to try and load the OS from another device though. Or try using VMware player.

I don't know just guessing.

well, for a start, I don't have VboxCD.dll , and I saw that Avira Antivirus gets in way. is it true?

At least I think it says VBoxCD.dll, its hard to tell in the screenshot of your error (or my eyes are just getting bad).

You could try disabling AV and see if it works. If the dll isn't there you may have to reinstall VB again.

well, reverting back to 4.3.12 solved the problem, but i still cannot install.. everything goes fine till install step.. and then faliure..

Your going to have to be more specific than "failure". Do you get an error? What happens?

something like "installation step failed" and so on.. when i click continue, i get to a menu where all the installation steps are listed

Which installation step fails? GG Dill_ for helping.
EDIT: replied at the same time.

Try it again and maybe snag a screenshot so we can see the error? Does it say what step it was on?

after restarting it worked.. wonder what went wrong though.. seriously, this error was brain-hurting me...

Glad it worked. Have fun.

thanks CIUFFY. Really appreciate you guys

Share Your Thoughts

  • Hot
  • Active