Forum Thread: Wifi Adapter Stopped Working on Windows but Still Works on Linux

Wifi Adapter Stopped Working on Windows but Still Works on Linux

I have this wifi adapter which was working perfectly on my windows 7 computer until it was hit accidentally by my brother... So now windows won't even recognize it!

I tried reinstalling it's driver, installing it on 3 other computers (1 desktop with windows 8, 1 laptop with win7, 1 laptop with win 10) but none worked too.. and tried it on 3 linux systems (mint, kali, ubuntu) and it's working fine.

Can you help me please.
If you need any more details just ask!

1-I want to know the reason behind this,
2-And if I can fix it,
3-And also can I use it with kali linux aiecrack-ng (I couldn't find the chipset model.)

4 Responses

it is :
SMC Ez connect G Usb 2.0

I want to know the reason behind this, And if I can fix it, And also can I use it with kali linux aiecrack-ng because I didn't know the chipset model.

try installing another driver from the manufactuers site
try a older one.

I tried that too and even determined the chipset and the driver on linux then went back to windows to find the driver and nothing worked...

No fix no problem(I use linux by default).. Can anyone help with the other answers..

Share Your Thoughts

  • Hot
  • Active