Forum Thread: Live Kali Persistence Worked Only Once

Hey there

I've being trying to create a persistent live kali using my Pendrive(16 gb) but it wont work.

Steps I Followed

Step 1: Burn Kali Image on My Pendrive

I downloaded the last version of live kali and installed on my Pendrive. No big deal here.
The following steps I repeated over and over again in some different ways. So I will write the last one.

Step 2: Resize the Usb

Using EaseUS Partition Master tool (on windows) I resized the pendrive but didn't create a partition (yet).
I left 6gb to the live kali and 10gb (these are not the exactly values but it's around it).

Step 3: Run Live Kali and Create a Partition

So I rebooted my pc, Ran kali using the default option (because I just ran to create a partition once I can't do it in the right way on windows) and using GParted I created a partition in my pendrive using the following settings:

  1. format: ext4
  2. label: persistence
  3. space: something aroung 10gb

Step 4: Run Kali on Persistence Mode

I just rebooted again I ran this time on kali persistence mode. So I opened my terminal and typed: "fdisk -l" to see which side I should mount. It was sdb2... So I followed the step that every tutorial website (including this one) teaches:

Created a new folder on mnt called my_usb:
mkdir -p /mnt/my_usb
Mounted the sdb2:
mount /dev/sdb2 /mnt/my_usb
Created the persistence.conf file:
echo "/ union" > /mnt/my_usb/persistence.conf
And yes. A driver called persistence showed up with the persistence.conf inside it.
And unmounted the sdb2:
umount /dev/sdb2

Step 5: Reboot Again and Test It Out

So I rebooted the system choosing the persistence mode again. Created a folder called "test" on desktop and rebooted again. Then the kali loaded with the folder there.

So I changed some stuffs there like keyboard, wifi password and files. Rebooted and everything was there just fine.

Step 6: So Everything Is Right, Right? Nope.

So I shuted down. Booted windows, removed the pendrive and plugged it again. Then rebooted the system and from usb choosing the persistence mode again and guess what? Everything lost.

In the previous attempts of mine something similar happned so I wonder: What I did wrong? Anyone could help?

Thank you all!

Get The Weekly Null Byte Newsletter

Never miss a Null Byte guide.

2 Responses

Could you describe a bit more the problem pleas? We can't help you if you don't give us more information : )

how did you get on?

Your information was clear enough for me to understand so it is a shame nobody could help

The issue i am having it basically not working after creating persistence.conf

Share Your Thoughts

  • Hot
  • Active