Forum Thread: Alfa AWUS036NHR v2 Don't Show Up in Kali

Alfa AWUS036NHR v2 Don't Show Up in Kali

I recently bought the AWUS036NHR v2 and it worked with windows.

But after i tried it in Kali(on my vm and from a live usb) the adapter didn't showed up. If i try to install new driver i get a bunch of error messages like

  • /root/Desktop/RTL8188C8192CUSBlinuxv4.0.29000.20130911/driver/rtl8188C8192Cusblinuxv4.0.29000.20130911/osdep/linux/osintfs.c:348:21: warning: assignment makes pointer from integer without a cast

padapter->dirdev = createprocentry(dev->name,

  • /root/Desktop/RTL8188C8192CUSBlinuxv4.0.29000.20130911/driver/rtl8188C8192Cusblinuxv4.0.29000.20130911/osdep/linux/osintfs.c:594:7: error: dereferencing pointer to incomplete type

entry->writeproc = procsetampduenable;

Image via gyazo.com

I know it should be easy to google but i just dont have a idea what i should type.

4 Responses

Hello BitScythe,
First I will try to solve your problems on vmware...
1.Make sure that your alfa adapter works for your host.

2.Then you need to add your adapter in your vm settings for kali under a tab called 'USB' and you need to plug in your adapter for detection.

3.Lastly, start and log in into your kali.
4.Remove your adapter and reattach it.

Second, for your Live USB.

If you want to install any driver, you need to have a persistence on your USB, if not, all the changes that you made will be reverted once you logged out.

p/s: I'm sorry if my english is bad because it is not my main language.
If my explanation is wrong or insufficient, I'm sorry.

Have a good day.

-JAB

Shit , i feel dumb af.
I forgot to add the adapter in my vm...
works now more or less(seems like it connect very long but at least i can see it with iwconfig)
thanks mate

The NHR Ver 1 and Ver 2 use 8188RU chip sets.
Ver 1 has been nuked for use in Kali, yet Ver 2 gets thumbs up on Kali.

So if you have a Ver 1 adapter good luck. If you have a Ver 2 then its probably the VM settings holding you back Like the guy up there says.

Help us help you and try your card with the Live Option and see if it works..

hi , when i'm typing airmon-ng , kali show , these : Interface : wlan0 ,Chipset : Unknown, Driver:rtl8192cu - phy2 . but windows show realtek rtl8188ru . why my card in windows and kali not same thing?

Share Your Thoughts

  • Hot
  • Active