Forum Thread: Problem Install/Running Amritage on Kali Linux

Hello, I've run in to a bit of a problem installing Amritage on kali linux on a windows computer. I've tried reinstalling and updating both kali and metasploit but I run into this text everytime I try to run amritage:

$ armitage Exception in thread "main" java.awt.HeadlessException: No X11 DISPLAY variable was set, but this program performed an operation which requires it. at java.desktop/java.awt.GraphicsEnvironment.checkHeadless(GraphicsEnvironment.java:208) at java.desktop/java.awt.Window.<init>(Window.java:548) at java.desktop/java.awt.Frame.<init>(Frame.java:423) at java.desktop/javax.swing.JFrame.<init>(JFrame.java:224) at ui.MultiFrame.<init>(MultiFrame.java:213) at armitage.ArmitageMain.main(ArmitageMain.java:200)

Sorry if this question has been asked already I've tried google but with no result.
Thanks a lot best regards Erik Ros

Never Miss a Hacking or Security Guide

New Null Byte in your inbox, every week.

1 Response

Also get this message when I check postgreql with ss -ant command, did I forget to give the kali permision or something similar? $ sudo ss -ant sudo password for lcvg: Cannot open netlink socket: Protocol not supported State Recv-Q Send-Q Local Address:Port Peer Address:Port

Best regards Erik Ros

Share Your Thoughts

  • Hot
  • Active