Forum Thread: Alfa AWUS036NEH Adapter Not Showing Wifi with Airmon

Alfa AWUS036NEH Adapter Not Showing Wifi with Airmon

Hey guys, I am having a little bit of an issue here. I was recently testing my wireless network at home and I ran into an issue. To be quite honest, I think this issue has only started since the merging of Aircrack-ng and Aircrack-zc...

I set my Alpha Dongle to monitor mode: <airmon-ng start wlan1>

Then I set up to look for wireless networks <airodump-ng wlan1mon>

I get the normal screen anyone would get, but no wireless networks pop up... What the heck is going on?

I tried it again with my internal wifi card by running through the same set of commands and BAM... A ton of wireless networks show up.

Could this be a software issue? Or maybe the antenna on my card is broken? I doubt this case though as I tried this while sitting within arms length of my wireless router...

Thanks in advance, guys!

EDIT: Dongle link

9 Responses

I have never used aircrack before, but I'm pretty sure it's:
airodump-ng mon0

The aircrack suite was actually updated (reference Kali.org blog or A previous post of mine).

Now instead of mon0, mon1, etc... It becomes wlan0mon, wlan1mon, etc...

EDIT: Added link (cannot access Kali.org from work)

That's weird. Maybe your kali hasn't updated?

I've updated using apt-get update and I've even tried updating aircrack myself.

I know that my Kali is good because like mentioned, I can run these commands and get the results I want with my internal wifi card.. Just not my Alfa dongle now.

If I didn't have the drivers installed for it, then would the Alfa information even be in the system? I am able to see that it is plugged in and I am able to see the driver using the airmon-ng command / ifconfig command..

Have you you tried?

ifconfig wlan1 down
iwconfig wlan1 mode monitor
ifconfig wlan1 up

or

iplink set dev wlan1 down
iwconfing wlan1 mode monitor
iplink set dev wlan1 up

I did the first set and even restarted with the dongle in, with the dongle out. No avail.. I will try the second set you have posted when I get home.. Thanks for the lead, I will keep you posted, Cyber!

It's OK the second set does the exact as the first its just the new way to do it. The ng suite perhaps is not playing nice at all.

This card should work out of the box...

Just start wlan1 with airmon and run wash -i wlan1mon see what it says

hi would some one help me not showing wifis

Share Your Thoughts

  • Hot
  • Active