Forum Thread: Live Boot Kali Linux from Kingston USB

Live Boot Kali Linux from Kingston USB

I've been trying to run Kali on my laptop with i7 processor, because right now I only have it on my Raspberry Pi, which can be tedious since that limits some of the hacks I can learn. Anyway, when I've written the .iso from kali.org/downloads to my USB, and I boot from USB from windows 10 I get the following message

Does anybody know how to fix this problem?
I've tried using chmod 777 on it, but I can't change the permissions.

9 Responses

You have to go to your BIOS settings (usually F2 on computer startup) and probably change security policy to a more permissive one. Each bios is different, so I can't tell step by step, but I can tell you to write down every change you make on the settings, because sometimes you might not be able to boot your primary OS with that changes (ye new bios can be a pain in the a$$). It usually solves enabling legacy bios instead of UEFI, but I found different ways for different BIOS, so you have to play a little with the security / boot settings.

i have a strange uefi so how do i open the bios because its really strange that i get not the normal bios :s

Triphat: Thank you so much, it's working now! :D I am writing this running Live Kali Linux

Abderrahman: As far as I know UEFI is the new BIOS, meaning it's replaced. I could be wrong, I'm not entirely sure. One way to open UEFI in windows 10, is to go to settings and choose recovery, then press restart, then advanced options.

Usually you press either F2, F1, F10, ESC, or Enter to enter bios but it depends on computer. Search your model up online to find the right combination.

Cheers,
Washu

All uefi are strange... but you usually get in with F2, or just look at the bottom of the screen when it boots, it might say to press ESC or F10, or any other key to go to the settings. Then you will get a nice bios-like interface you can operate with your mouse, and change the settings from there.

The thing with my computer anyway after I upgraded to Windows 10, is that I don't get the option to enter UEFI on boot. I have to do the method I said :/

the problem is i get just info about my pc not the settings

I believe that on the long run, UEFI will introduce more security problems that what it was meant to solve.

Just like triphat said, you have to enable legacy boot in order for it to function. This can be done from within the boot settings in your BIOS.

Cheers,
Washu

Share Your Thoughts

  • Hot
  • Active