Forum Thread: [Help] Persistent Kali Live Stops During Boot (Multiple Mounts)

[Help] Persistent Kali Live Stops During Boot (Multiple Mounts)

Hello! This is my first post on this website (yay?) although I have been following it for well over a year I would say. Not that this account is that old since I made it a few months ago. Anyways, to the point.

I have a PNY 128gb 3.0 USB with Kali Linux 2.0 that I use to live boot. When I setup the persistence I seemed to have messed something up. When I boot into it I select USB Live Persistence and it boots normally until a certain point. It stops here:

Realizing now just how crappy of a picture that is, sorry.

This is what seems to be causing it:
(initramfs) mount: mounting /dev/sda on /live/persistence/sda failed: No such device.
mount: mounting /dev/sdb on /live/persistence/sdb failed no such device
mount: mounting /dev/sd0 on /live/persistence/sd0 failed no such

Two persistence mounts have the same or nested sources: /live/persistence/sdb2/union on /root/union, and /live/persistence/sdb2 on /root

modprobe: module ehci-orion not found in modules.dep

It allows me to type and by simply typing exit, it continues and I am allowed to boot into kali with persistence working.

Also, I am trying to get kali to boot on my desktop but when I get here the USB Keyboard is not on. I was wondering if there is something I have to do or when the issue is resolved and it can boot without me being required to type something during the boot, the keyboard/mouse will turn on itself.

Thanks.

Be the First to Respond

Share Your Thoughts

  • Hot
  • Active