Forum Thread: Kali Linux Can't Get Persistent Usb to Work?

Kali Linux Can't Get Persistent Usb to Work?

I have followed the tutorial from https://null-byte.wonderhowto.com/how-to/create-bootable-persistent-kali-linux-usb-with-ease-0166067/ here on null-byte. When Kali is running on the desktop there is the persistent partion. I tried leaving a test file to see if the persistence was working but the file was gone when i got back on. If i leave any files in the persistence folder on the desktop they remain in there when i get back. I'm just wondering if you guys can help me out and try and help me fix it. Thanks

3 Responses

I've followed that tutorial... It's kind of vague at some parts. Don't exactly remember what I did, but try reinstalling Kali on to the drive, and then follow the instructions in bold below:

fdisk -l # Lists drives
mkdir /mnt/usb # Don't replace usb with anything...
mount /dev/sda2 /mnt/usb # Replace sda2 with the drive name...
echo "/ union" >> /mnt/usb/persistence.conf # Writes / union to persistence file
umount /mnt/usb && reboot # Unmounts drive and reboots if successful

Thanks for the reply. I have followed these steps with no success, i have kali booted on a 64 gb usb with 4gb partition for the bootable iso and the rest partitioned as a primary ext4 partition i am able to access the drive and save stuff in their but anything outside the drive is erased after shutdown e.g. system settings don't save after reboot or files. I understand that i need to be using the correct partition which is sdb2 to be precise, just not sure whats going on . I will keep trying to fix the problem as again thank you for putting in the effort to come up with a response will be sure to let you know if i get it working.

I HAVE AN IDEA

Use another memstick. A smaller one with kali Live installed. Then have your other 64gb memstick plugged in. Boot up from the smaller memstick with Live Kali installed on it, and then from there you install it into your large memstick when it asks you where to install it to. Then you can skip grub loader install and you're good to go.

Now you can insert and boot that memstick from any pc that supports the version(32bit or 64bit) of kali you installed.

And when you come out, it should save.

Hopes this helps.
Cheers

Share Your Thoughts

  • Hot
  • Active