Forum Thread: Need Help with WLAN Metasploit, LAN Works Fine

Need Help with WLAN Metasploit, LAN Works Fine

I want to use a metasploit payload I made via WLAN instead of LAN. I got lan working fine using my local ip and port 4444.

However, when I create the payload using LHOST = myPubIp, and using ports 443, 80, 8080, 4444(tried all these) it does not connect, rather it just says failed to bind. When creating the payload do I have to set LHOST as my local IP and set RHOST as my public IP? Or do I need to just use a specific port, like 91 and forward all traffic to my local IP?

Thank you!

11 Responses

first you need to port forward the port you use (4444 or other ones),as for RHOST you will use the ip of the victim,also if you use TCP reverse make sure you allowed it to go through the firewall.

Thats all D3ATH

hye every one i need some help here i want to port forward 443 i think thats https port and i want to use it in my kali linux payloads but whenever i port forward from PtclRouter AdvancedSetup>>NAT and Add option for port forward and then i use canyouseeme-org it still shows he cant see any service on my public ip 39.XX.XX.XX.. kindly tell if some can help me in this problem

ups

make sure you have that port in outbound rules of your firewall.

kindly describe it a little deeply.. i dont understand.. or i will be very thankful if u send screenshots too

thanks for ur fast rply i want to ask that my ip of kali linux maching is 192.168.218.134 instead of something like 192.168.1.2.. that can make any type of problem here?

i added up a new rule for remote port 443 now it gonna work?

still not working :/

Thank you for your help.

So when I create the Veil Evasion exe, I set my Lhost to my public IP correct? and LPORT to 4444?

Also, In netgear I am kind of confused on port forwarding, but as the start and end port I used 4444 and as the service IP i put my local IP. IS that how its supported to work? Or should I of put my public IP?

By allowing it through the firewall you mean on router settings correct? Ill take a look.

Thanks!

When I do check if my port is opened on Canyouseeme.org it puts my public IP in as default and I enter port 4444 but it says its not opened. So am I doing port forward wrong in netgear?

Share Your Thoughts

  • Hot
  • Active